need help on nginx server block

Technical Support

Suggested Topics


  • 0 Votes
    7 Posts
    9k Views

    Thanks @rod and @tqwhite for helping @Cyb3r with this šŸ˜„

    Glad we have you on the community!

  • 0 Votes
    7 Posts
    3k Views

    @baris ,

    Social sso plugin problem solved I can now select ssl option
    Ā 

    Still get

    [plugins/load] The following plugins may not be compatible with your version of NodeBB. This may cause unintended behaviour or crashing. In the event of an unresponsive NodeBB caused by this plugin, run ./nodebb reset -p PLUGINNAME to disable it.

    nodebb-plugin-emailer-local

    And Emailer not installed , any suggestions?

  • 0 Votes
    5 Posts
    3k Views

    @baris said:

    The error message is telling you that it can't access/save the file. Make sure the user you are running the commands has the proper permissions.

    I wondered that too, I was using a user I specifically created for this task in order to not use the root user as I thought it was not a good practice to do. Especially since the instructions indicate a sudo user. Usually I can figure out permission issues, but for some reason I have not been able to solve this one. The installation does get further when using the root user, so there is definitely a permission issue.

    The error I get now is related to the connection of the Redis database. I get a connection refused error when using the IP of the server.

    The abort error shows the IP address and default port number so I have no idea how to connect the database.

    Here's the latest console information ...

    [email protected] node_modules/connect-redis ā””ā”€ā”€ [email protected] ([email protected]) 25/4 19:08 [21628] - info: Populating database with default configs, if not already set... 25/4 19:08 [21628] - error: Error: Redis connection to myserverIP:6379 failed - connect ECONNREFUSED at RedisClient.flush_and_error (/mydomainpath/nodebb/node_modules/redis/index.js:142:13) at RedisClient.on_error (/mydomainpath/nodebb/node_modules/redis/index.js:180:10) at Socket.<anonymous> (/mydomainpath/nodebb/node_modules/redis/index.js:95:14) at Socket.EventEmitter.emit (events.js:95:17) at net.js:441:14 at process._tickCallback (node.js:415:13) 25/4 19:08 [21628] - warn: NodeBB Setup Aborted. Redis connection to myserverIP:6379 failed - connect ECONNREFUSED

    Thanks ... Pops

  • Nginx 1.8.0

    NodeBB Development
    0 Votes
    2 Posts
    2k Views

    Heh, and I'm running 1.4 on my local env šŸ˜„

    I thought hash load balancing has been in nginx for awhile... hm

  • 0 Votes
    8 Posts
    9k Views

    @fr3em1nd said:

    @a_5mith yep

    fuser -k 3000/tcp

    seem to fix it so it will kill all to processes using that port

    It may do work. But it is not very clean and can lead to serious problems to solve problems of this kind that way.
    Just a little advice. No offence. šŸ˜‰