Problem with widget



  • Hi guys, i set a html global header in the ACP. Then i delete it, the html box is no there anymore but the html code (actually it was a script) is still working. I have restarted/reloaded the forum and uninstalled the widget plugin but when i reinstall it the script works again.

    So where can i edit the html files to remove the script by hand?Any other solution?

    Thanks and sorry for my english.



  • Chec you've not got it cached. Once removed from widgets. It should be gone completely. Try in a private browser too.



  • @a_5mith said:

    Chec you've not got it cached. Once removed from widgets. It should be gone completely. Try in a private browser too.

    Thanks for answering.

    I have done everything you said and still not working, also I tried it on 3 different computers.
    I remove the Global Footer too, but it is still there.



  • @Ait0r Got a link to your site or is it local only currently? Can send over chat if you'd rather keep it personal for now.



  • @baris or @julian, you aware of any issues with widgets in 0.7.0? Seems they don't want to delete, been through ./nodebb reset widgets and all manner of other logical approaches.

    Output of api/widgets is

    [{"location":"sidebar","widgets":[]},{"location":"footer","widgets":[{"html":"<footer id=\"footer\" class=\"container footer\">\r\n\t<div class=\"copyright\">\r\n\t\tfsdfsfsdfsdfsdfsdf14gg <a target=\"_blank\" href=\"https://nodebb.org\">NodeBB Forums</a> | <a target=\"_blank\" href=\"//github.com/NodeBB/NodeBB/graphs/contributors\">Contributors</a>\r\n\t</div>\r\n</footer>"},{"html":"<footer id=\"footer\" class=\"container footer\">\r\n\t<div class=\"copyright\">\r\n\t\tCopyright © 2014gg <a target=\"_blank\" href=\"https://nodebb.org\">NodeBB Forums</a> | <a target=\"_blank\" href=\"//github.com/NodeBB/NodeBB/graphs/contributors\">Contributors</a>\r\n\t</div>\r\n</footer>"}]},{"location":"header","widgets":[{"html":"<script>\r\nif (!app.uid && ajaxify.currentPage !== 'login' && ajaxify.currentPage !== 'register') {\r\n ajaxify.go('login');\r\n}\r\n</script>"}]}]
    

    So his issue is the script at the end is broken, so it's looping him between /login/ and the users profile endlessly. I noticed cachebuster hadn't changed, but I'm not sure how to get Cachebuster to forget and restart everything.


  • Admin

    er... no, not that I'm aware of, but @psychobunny may have a better idea...


  • Admin

    Couldn't repro yet so git revision and content of the widget that causes this might be useful also the theme that it's happening on if it's specific to a theme.



  • @baris it happen on both themes (vanilla and lavander)
    and this is the script

    <script>if (!app.uid && ajaxify.currentPage !== 'login' && ajaxify.currentPage !== 'register') { ajaxify.go('login');}</script>
    


  • Type git rev-parse HEAD In your nodebb folder. And paste the string you get out of it.



  • I backup and reinstall nodebb v0.6 instead of 0.7 and the problem is solverd.
    Thanks for your time


 

| |