My site was there --- and then was gone


  • :|
    It's down again. It was doing well. It made it through a restart and set itself back up.
    I installed the Forever Service --
    but now its down again. Forever service isnt starting it, ./nodebb start isn't starting it.
    I was just about to work on getting the site onto a domain - and then it was gone
    http://107.170.196.59:4567
    What is causing it to drop off like that, and what can I do to stop it?


  • @birch go to the console on the Digital Ocean website; Switch to the Directory you have the forum in then type "nodejs app" and then let it run.


  • ive been using putty, does it matter which one I go to?


  • @birch I use the one on the website to start the script just so it stays running.


  • i haven't used it much because I can't right click/paste into it.
    So, I did that, went into the correct directory and did as you said and it still says servers unavailable
    image
    edit it wont recognize the commands if I log in as other than root - not sure if that is the norm.


  • @birch Did you make your created account a Super User? (Put it in the Root Group.) Might want to Restart the Server as well.


  • Yes, Im quite sure the added user was done correctly -

    I'll restart the server.


  • @birch Also, make sure you're in the right Folder when you're trying to start it. Do "CD Folder name" and then nodejs app.


  • alright, so server is restarted. I think I have supervisor installed - did have the Forever Service but removed it.
    went to the directory - entered ./nodebb start - but still not working.


  • @birch Did you put in a redis password during installation ?


  • @Tiki - not that I recall, no.


  • @birch did you install NodeBB under root? or the user you created?


  • It was installed in root - before I created another user.


  • @birch You need to re-install under the user you Created. I'll be uploading an Updated guide soon if you're wanting something to help with that.


  • Yes, that would be great. ugh... have to do it again? lol this hurts my brain :)
    I also want to install it into a domain this time. Is that able to be done while installing it? Or is there something else I have to do. I might as well just destroy the other droplet and create new.
    (Digital Ocean said I should be using a larger package for the NodeBB - but I had read that the 512 would be enough, especially with not having a user base)


  • @birch It's possible, usually easier through IP.


  • The issue you're seeing is because of the emailer-mandrill plugin. It appears to be for a different version to what you're running. You can run ./nodebb reset nodebb-plugin-emailer-mandrill

    Then start the forum. Also in your config.json you have supplied a password, but not put the same password into redis.conf in /etc/redis/. It doesn't matter, but if you want to secure your forum, put a password on Redis.


  • @a_5mith do you have a suggestion for keeping the site online? Should I reinstall Forever Service? (which seems different than the Forever Daemon suggested here https://docs.nodebb.org/en/latest/running/ ) - right now ill deal with the mandrill - it was an optional plug in in the ACP so I thought it would be good to install it :)
    still won't come up
    wasn't sure whether to use ./nodebb start or node app - tried both.
    ./nodebb start seems to indicate the process went fine but still down.
    node app gave me this:

    I think I'll just delete the droplet again.
    ill create a new user -sudo and install it in that directory.


  • @birch said:

    I think I'll just delete the droplet again.
    ill create a new user -sudo and install it in that directory.

    Completely unnecessary. Just fix the errors you are seeing and it will work just fine. There should be no reason your forum is going offline, mine has been up and running since March with no downtime (except for me stopping it to run an update etc).

    Cannot read propety buildHeader of undefined is an error with you running a plugin not designed for your version of nodebb. What version of NodeBB are you running? If 0.6.x, you need the latest version of whatever plugin is giving you that error. If you're running 0.5.x, then either update to 0.6.x, or run the version of the plugin before the 0.6.x changes were added.


  • support at DO told me it was best to destroy the droplet and start over (and suggested my 512 ram would be too small to run Nodebb)
    I don't know how to fix the errors because I can't get my forum online to deactivate and uninstall the plugins.
    My first install was based on psychobunnies tut that I had found when searching 'installing NodeBB'
    that was outdated it seems - and I had a really really hard time installing it.
    It was up and running. I was so thrilled. Then the next day I woke up and it was gone. Support was unable to help me and told me to look at NodeBB documentation.
    Then above, once finding out that it was outdated info and getting a link to the newer installation - I started over. Much easier this time - but still must have missed soemthing because two hours later it was down. However initially ./nodebb restart worked.
    Now it does not. So - droplet destroyed I will try again. I know the docs are simple - but for me it is quite foreign. I was proud of myself for getting ghost running :D

Suggested Topics

| |