[nodebb-plugin-minecraft-integration] Minecraft Integration!


  • @yariplus Thank you for being an active author, I have one question though, will there ever be support for voting site links on this plugin?

  • Community Rep

    @Archeon Interesting idea, it would work well with some of the future plans I have for the plugin.

    I checked out a few of the most popular voting sites, and only some of them had an exposed API, I'll have to investigate further and possibly contact them.

    Which of the voting sites are you most interested in? I'll make sure I get it working with them first.


  • The two major ones at the moment server / network owners care about.


  • @yariplus plugin doesn't show up, in admin menu
    I'm using nodebb 0.9.0 and i tried installing through npm, ACP and grabbing the latest version from git. If you have any ideas what I'm doing wrong, that be really nice, request logs and I'll send you whatever you need!

    edit: and yes I activated the plugin in the ACP
    edit2: figured it out, the plugin needs lwip a requirement which isn't specified for whatever reason as dependency, to fix run "npm install lwip" in the nodebb root folder

  • GNU/Linux Admin

    @yariplus Yikes, I didn't know us removing the lwip dependency was an issue for plugin developers. Can you use jimp instead? It's more lightweight and doesn't take 2 years to compile.

    https://github.com/oliver-moran/jimp/

  • Community Rep

    @phit said:

    @yariplus plugin doesn't show up, in admin menu
    I'm using nodebb 0.9.0 and i tried installing through npm, ACP and grabbing the latest version from git. If you have any ideas what I'm doing wrong, that be really nice, request logs and I'll send you whatever you need!

    edit: and yes I activated the plugin in the ACP
    edit2: figured it out, the plugin needs lwip a requirement which isn't specified for whatever reason as dependency, to fix run "npm install lwip" in the nodebb root folder

    Ahh, thanks for the heads up. As @julian says, lwip was originally in core, which is why I don't have it in dependencies.

    Jimp definitely looks doable. I'll switch to that asap.


  • @yariplus i also can't get the bukkit plugin to work, is there a newer version somewhere than 0.2.0? and if so is it compatible with kcauldron and 1.7.10?

  • Community Rep

    @phit Pushing it now.

  • Community Rep

    Grr, jimp doesn't have the nearest-neighbor algorithm I require.

  • Community Rep

    v0.6.0 Changes

    This plugin now REQUIRES the Bukkit plugin NodeBB-Integration

    The plugin no longer pings or queries Minecraft servers, you need to add the plugin's API key to your NodeBB-Integration config in order for this plugin to work. This means you can no longer add a widget of someone else's server, and you may have trouble configuring this plugin if your server uses an old version of Minecraft. I made this change for my own sanity. Interpreting pings and queries added a lot of complexity to the code. Interacting with a Minecraft plugin is much cleaner and simpler to code, and now I can more easily add new features.

    New Features

    Admin page now has tabs showing all data cached in the database with some buttons for management.
    Configurable avatar borders and chart colors are back.
    Added extra Widget color options.
    Added an Avatar CDN for Mojang (now the default) and The Brony ModPack.
    Added a Steve default avatar if the configured CDN fails.
    Chat widget now sends web messages to the server.
    Redid a lot of the client scripts for better loading times.
    Changed image manipulation library from lwip to jimp.
    Vault Integration: The plugin will now add the Vault prefixes of your player to your forum name.

    Note: Upgrading to 0.6.0, you will lose all of your <v0.6.0 settings.


  • @yariplus I'm a bit lost with the Minecraft scene at the moment. But wasn't Bukkit killed due to DMCA requests?

  • Community Rep

    @Kowlin It's very much alive at the moment.

    From what I can tell, the DMCA thing was a case of license abuse from one of Bukkit's own devs. Do to the viral nature of GPL, the dev was able to make some rather ludicrous claims. And since Repo's would rather not get involved in legal concerns despite the circumstances, they shut it down immediately. The situation seems to have ironed itself out, devs with local access to the code removed the salty dev's commits and development continues.


  • @yariplus Ahh that explains alot, thanks ;)

  • Community Rep

    I have re-published the old package [nodebb-widget-minecraft-essentials]

    Many people have been downloading this despite it being out-dated, probably because of it's invalid nbbpm version.

    I used to redirect it to minecraft-integration, but this was confusing and required extra work that I frequently forgot to do. Instead, I have made it into it's own plugin.

    The new plugin has config for one server and queries every minute for a single server status widget. There is no setup required, and you can use vanilla or legacy servers.

    It's not really worthy of it's own topic, but I'm posting this here so that admins still using the old package understand what happened if widgets disappear.

  • Community Rep

    v0.6.6 Changes

    minor update

    Vault Prefixes now appear on user profiles. I'll be adding them other places too, but this was the most requested.

    It works with vanilla, lavender, and persona. And most themes based on them.

    It's Princess Carpet! Yay!!!

    Additionally, avatars are now served with last-modified headers so that they are cached on the client-side. This should drastically improve loading speeds for larger servers.

    nodebb-widget-minecraft-essentials

    I made a bunch of performance improvements to nodebb-widget-minecraft-essentials too, and added a new feature, a mini server status on the site navbar. It displays the onlines status (optionally showing the server's icon) and online players, which are dynamically updated. I'll likely add this feature to minecraft-integration once I've fleshed it out a it more.

    navbar status

    FYI, If you are using nodebb-plugin-minecraft-integration and want this feature from nodebb-widget-minecraft-essentials right away, you can install both plugins, they do not interfere with each other in any way.


  • Pre- & Suffixes, the most stylish way of letting someone know that you're above the others ;). Regardless it looks quite nice I must say.
    Edit: Taken from my Discord server


  • Hi there,

    I am using Spigot 1.8.8 and the latest version of nodebb and your plugin.
    However, I keep receiving the error that the plugin cannot connect to my forum. Could this be due to me using http://cloudflare.com as a CDN?

  • Community Rep

    @Lettuce possibly, but only if you don't have websockets setup correctly.

    Skype or chat me the output of /nodebb debug


  • Hey, When I use the plugin on the nodebb website, whenever I click the "add server" button nothing appears to happen.

  • Community Rep

    @Garispl Are you using the latest master branch? It's not compatible yet if so. I'll post an update for it asap.

Suggested Topics

| |