@Scuzz I made this point in a github issue, sort of. The nbbpm plugin system that's being implemented was backported to 0.5.x stable. Which is still technically 0.5.4, the issue with backporting into an existing version, is although their has technically been an update, it's still 0.5.4, so the NodeBB system will tell you you're up to date.
This basically means that you could be running an old 0.5.4, and I could be running a 0.5.4 with the nbbpm backported software, my version would tell me not to update because of incompatability, your version wouldn't. I have recommended that any changes, no matter how small, be marked under a new version, when a software is released as 0.5.4, this is it. A bugfix or a backport should become 0.5.5 when stable. Which I believe is the steps that are now being taken. I've seen a lot of similar issues, so I feel a sticky or an email to all users on the forums regarding this may be warranted.
To fix your plugins, you will need to downgrade any affected plugins, this can be done manually through github, look at the commits and look for the latest version before any 0.6.0 compatability commits. For example, widgets essentials should be 0.1.2 etc. Then update as your normally would, but instead add @x.x.x. to the end of the plugin name. Replacing x.x.x with the version of the plugin prior to the 0.6.0 compat changes.
It's unfortunate that this has happened to so many users, and is probably quite a jarring issue to have. I can't say I have the time to create a topic that will list every plugin and every version people should be using. But, it is something that can be prevented in the future.