Might as well add another cog to my plan im on cent os


  • Let's confuse the issue deeper...

    Site just went white in my browser. too long to read error in the error.log for nginx.

    I open up Chrome, it works.
    I open up my iPad, it works (also a Safari based item).

    So something in Safari/desktop is not playing nice with the site.

    BUTTT (there's always one)

    The site does not show stats, admin info, etc. in ANY of these broswers or devices unless I load the site up with the port # info :4567 -- also the same re: Login showing after signing in and getting Admin access.. all that happens over everything.

    So I'm thinking it's a nginx setup issue because it's obviously not node/forever/etc.. they're all ok.. it's something with the proxy/nginx config.


  • Okay. I tried a bunch of things systematically when I get the white screen. End result is if I close/open a tab and retype in addy it loads up.. so the process there is crapping out, but it's still up.. that's why @julian you see it when checking 🙂

    Now the real and final issue here is the :4567 showing the data / #'s etc.. correct, and the url without port is not per the screenshots.

    Once that's fixed I can finally pull in the other database. I'm sure that will be a treat.

  • GNU/Linux Admin

    When NodeBB doesn't show the forum stats, that's usually because it is unable to connect with websockets, and will eventually fall back to XHR polling. At least... that's the hope

    If you stay on that page for 10-20 seconds, do the stats come up eventually?

  • GNU/Linux Admin

    On the bright side, @outlawedoffroad - think of all the sysadmin skills you're gaining!


  • When NodeBB doesn't show the forum stats, that's usually because it is unable to connect with websockets, and will eventually fall back to XHR polling. At least... that's the hope

    If you stay on that page for 10-20 seconds, do the stats come up eventually?

    Only the first stat.. or in ACP some come in some don't. But yeah it's 10-20 seconds.

    I used to run old school BBS's back in the day 10-20 years ago compiling C++ and whatever with my old WWiV systems so I don't mind troubleshooting as long as I know there will be an end to the rainbow.


  • Oh and the delay is now over all browsers, nothing is spared from the chaos of the delay!

  • GNU/Linux Admin

    Please attach your nginx config file, and your nginx version.

    ** For reference, nginx must be v1.3.13+, or else WebSockets will not work! **


  • I did it all from the guide on the wiki but nginx is only @ 1.1.19 whats the upgrade command I'll slap that bitch in place and cross my fingers 🙂

  • GNU/Linux Admin

    @outlawedoffroad - take a look here


  • @outlawedoffroad - take a look here

    hmmmm tried it quick still stayed @ 1.1.19 leme try again later tonight when i have more time..

  • GNU/Linux Admin

    You'll have to do a yum install or update, whichever it is for your OS.


  • Okay this thread is done....

    Site working, everything updating proper.

    Now to shake e how to move a data be thread while I break something else.

  • Admin

    lol congrats, I was getting |-) of reading this thread everyday 😄

  • GNU/Linux Admin

    Hahaha, you don't appreciate his play-by-play? 😛


  • every problem I post, is another search engine nugget someone may need down the road...

    you're welcome 🙂

Suggested Topics

| |