• Hi,

    During installation I got these warnings:

    npm WARN engine hawk@0.10.2: wanted: {"node":"0.8.x"} (current: {"node":"0.10.31","npm":"1.4.23"})
    npm WARN engine boom@0.3.8: wanted: {"node":"0.8.x"} (current: {"node":"0.10.31" ,"npm":"1.4.23"})
    npm WARN engine sntp@0.1.4: wanted: {"node":"0.8.x"} (current: {"node":"0.10.31" ,"npm":"1.4.23"})
    npm WARN engine hoek@0.7.6: wanted: {"node":"0.8.x"} (current: {"node":"0.10.31" ,"npm":"1.4.23"})
    npm WARN engine cryptiles@0.1.3: wanted: {"node":"0.8.x"} (current: {"node":"0.10.31","npm":"1.4.23"})

    and

    npm WARN package.json nodebb-plugin-soundpack-default@0.1.1 No README data
    npm WARN package.json nodebb-plugin-dbsearch@0.0.13 No repository field.
    npm WARN package.json reds@0.2.4 No repository field.

    I'm using ubuntu @ VirutalBox to test.

    I installed the forum, but now I can't login with the user I created during setup.

    Any help?

    Thanks!


  • @Distanasia What database are you using? Redis? If so, what does the output from redis -v state?


  • @a_5mith disse:

    @Distanasia What database are you using? Redis? If so, what does the output from redis -v state?

    Yes. You mean the version, right? It's Redis server version 2.2.12 (00000000:0)

    Sorry, I never used this database before.

    I just followed this tutorial

    Thanks!


  • @Distanasia Not a problem, it appears your Redis version is out of date, NodeBB requires Redis version 2.6 or above.

    Go through the following commands one line at a time from your users root folder (assuming you're using a non root user with sudo permissions) if you're running as root, remove sudo from each line.

    sudo apt-get install -y python-software-properties
    sudo add-apt-repository -y ppa:rwky/redis
    sudo apt-get update
    sudo apt-get install -y redis-server
    

    Once you've done that, you should be good to go. You can check by running redis -v again and making sure it's 2.6 or above.


  • Thanks @a_5mith ! 🙂

    I logged as administrator, but during setup I still got this warning:

    npm WARN package.json nodebb-plugin-soundpack-default@0.1.1 No README data
    npm WARN package.json nodebb-plugin-dbsearch@0.0.13 No repository field.
    npm WARN package.json reds@0.2.4 No repository field.

    Thanks!


  • @Distanasia You can safely ignore those.


  • Thanks for the help @a_5mith ! 🙂

    nodebb is new for me! I'll test @localhost first, and learn how it works! Thanks!

Suggested Topics

| |