[Solved] Composer does not clear after submitting a reply.

  • @julian can confirm this bug, it happened to me today a few times, (I've been downloading about 50GB worth of stuff onto my new PC and not sure if it's that that caused it, will see with this reply.

    Edit: it didn't happen, but I will try when I'm maxing my net out again, as it could be linked.

  • @julian said:

    Could it be that your server is crashing? When you try accessing those links, the server may be back up.

    Try running your server in development mode (./nodebb dev) and see if you can trigger it again.

    It could be, but the log is clean. I'll run it in development mode for a while and see.

  • So it does seem that something is causing the NodeBB service to restart. I created a test thread with lots of markdown and submitted a bunch of replies to myself and then started doing some quoted replies and I noticed the NodeBB service repeating the info and warnings it gives when it first starts up.

    Whatever happened before then was quickly scrolled off the screen, and I don't know where I might find any logs to see the problem.

  • @Shaun Run the forum in ./nodebb dev and leave the Terminal window open, when it crashes, it will show you the full output, not just from when you went to nodebb log. 👍

  • @a_5mith I was, but I'm not the most proficient linux user so I hadn't figured out how to scroll back in the log. Now that I have, this seems to be the error:

    error: TypeError: Cannot read property 'uniqueId' of null
    at shouldPush (/home/shaun/nodebb/src/notifications.js:163:30)
    at /home/shaun/nodebb/src/notifications.js:132:5
    at /home/shaun/nodebb/node_modules/async/lib/async.js:125:13
    at Array.forEach (native)
    at _each (/home/shaun/nodebb/node_modules/async/lib/async.js:46:24)
    at Object.asnyc.each (/home/shaun/nodebb/node_modules/async/lib/async.js:124:9)
    at /home/shaun/nodebb/src/notifications.js:127:10
    at /home/shaun/nodebb/src/notifications.js:34:12
    at /home/shaun/nodebb/src/database/redis/main.js:68:4
    at try_callback (/home/shaun/nodebb/node_modules/redis/index.js:573:9)

  • Further detail:

    The composer window is locked open, but pressing discard will remove it. I can toggle the display with the thread button (bottom right corner) but I cannot submit the reply (probably because it was already submitted).

    If I click the reply buttons in the thread while the composer is open, it does not clear the existing composer window and the submit button is still unavailable.

    If I quote an existing reply, it updates the text of the composer with the quoted post, but submit button is still unavailable.

    Pressing discard results in the [OK/Cancel] modal popup, and confirming on that popup does clear the composer.

  • Seems to be happening every time I submit a quoted reply right now. Same error, same line numbers.

  • @Shaun said:

    Seems to be happening every time I submit a quoted reply right now. Same error, same line numbers.
    Quoting seems to work for me here. :s

  • NodeBB Admin

  • @baris I can probably figure it out, but would you care to supply the specific commands to pull that down from git so that I can't screw it up?

  • NodeBB Admin

    If you are on the master branch just a git pull should be enough to get the latest.

  • Haven't seen it happen since the pull.

Suggested Topics

| | |

© 2014 – 2022 NodeBB, Inc. — Made in Canada.