[nodebb-plugin-pushbullet] Push Notifications for NodeBB

  • GNU/Linux Admin

    @pitaj ping pong.

    It's likely new associations don't work, though I can't imagine why (since the pushbullet plugin code hasn't changed so substantially to necessitate a re-auth)...

    I've been getting pushbullet notifs from you though 😄

  • Plugin & Theme Dev

    @julian said:

    @pitaj ping pong.

    It's likely new associations don't work, though I can't imagine why (since the pushbullet plugin code hasn't changed so substantially to necessitate a re-auth)...

    I've been getting pushbullet notifs from you though 😄

    so, do we call it as broken for new users?

  • I'm running NodeBB v0.6.1 and pushbullet plugin v2.0.4. Here is the interesting "stuff".......

    From the first install, I have not been able to get the Pushbullet menu to pop up in the profile dropdown. I looked through the code and found the reference to the settings page /pushbullet/settings and then started down that road. I do have a newly created pushbullet account and was able to register the app through the link provided.

    The Pushbullet layout is a little confusing, but the layout is client ID in the first box, secret in the second. I found this by switching them in the many testing iterations in that you will get an invalid client ID during the authorization process if you have them in the wrong place.

    Once I found the /pushbullet/settings page and was able to start testing that process, I found that the URL being constructed as part of the approval message was jacked up (although, it was accurate for my configuration). My problem was that I used the following format for my "url" in the config.json:
    "url" : "http://localhost:443"
    I had modified this to get it to work via ssl and it would work just fine as long as you were not trying to reference from outside of the context of the config file.

    I was able to hack the url tag to "https://www.mydomain.com" , but the app kept starting with the default port. I got into the app.js file and found where the "url" field was getting parsed for the port number and I just hardcoded that into the app.js file.

    After reloading and again manually browsing to /pushbullet/settings, I was able to validate through the entire process and to the point of sending and receiving a test message!

    As I began to test further, I found that no other push notifications were being sent. I manually browsed to /pushbullet/settings once again and found the checkbox to be empty for Enable push notifications. I clicked enable, saved it, and everytime I refresh the page, it is cleared.

    I would associate this with that there is something missing as part of the config process (for both the menu item not appearing and the setting not holding). Doing a quick check of mongo, I am unable to find any reference to "pushbullet:enabled" in objects.

    Sorry for the long rant, just trying to provide insight to what I've found. I don't think the issue has anything to do with the pushbullet service or API, rather something is going on in the plugin itself with regard to fields existing, etc.

  • GNU/Linux Admin

    Will need @baris' help to test on Mongo, as I've only tested it for Redis. It may be that the config option is not saving properly. (true/false/0/1/etc)

  • New update. I was able to find where the settings field for "pushbullet:enabled" and "pushbullet:target" in Mongo. They are both set as to be expected, however, this isn't getting to the settings view.

    Screenshot 2015-02-17 16.30.26.png

  • The part of what I believe is part of the required data for this plugin to operate is 'pushbullet:tokens' and that doesn't not appear in a search.

    I am by no means an expert in any of this, just trying to assist in the resolution of this plugin not functioning.

    EDIT: I was able to find that key as well so now I'm back to why it doesn't work when everything appears to be there. I'm going to modify the if statements regarding the profile menu to see if I can pick out which portion is failing.

  • GNU/Linux Admin

    Seems there's an issue with Redis and Mongo and the plugin not handling true correctly.

    In any case, on Baris' suggestion, I will refactor it to save 0/1, so that should be easier to manage.

  • Plugin & Theme Dev

    updated to new version but still not working

  • GNU/Linux Admin

    @Martin What's the problem you're seeing?

  • Plugin & Theme Dev

    @julian the new associations doesnt work as previous versions. Using 0.7

  • Global Moderator Plugin & Theme Dev

    It still isn't working for me on this site either.

  • It isnt working for me either on this forum.

  • Is the plugin working? can I use it for NodeBB v0.6.1?

  • @Temo-Chitishvili19 y es it is working forma me un this forum right now.

  • I tried it on my forum about a month ago and it did not work, will try it again later today

  • I installed the plugin on my forum and when I send Test Notification, I get it on my phone, but I don't get post notifications, when somebody posts something. What can the problem be? Can you help me? The site is sufism.ge

  • GNU/Linux Admin

    @Temo-Chitishvili19 Are you getting the notifications in the dropdown? Or are they not appearing there either...

  • yes, I'm getting notification in the dropdown, no problem with that

  • the first time I installed the plugin I asked the other forum member to post something to test the notifications, and I got it on my phone, since then, it stopped working, maybe it worked that time because I was online on the forum. could it be this?

  • GNU/Linux Admin

    If you're in the topic while he posts, then you won't get a notification, otherwise one should be sent.

Suggested Topics

  • 4
  • 1
  • 4
  • 5
  • 15
| |