[nodebb-plugin-emoji] Emoji Plugin

  • NodeBB

    I think he means the ACP>Plugins list

  • @baris Oh, OK then. 😆

  • Plugin & Theme Dev

    @julian ya, it's as @baris wrote: emoji-extended doesn't show up in ACP > Plugins list when not installed because the package list doesn't contain it somehow 😉

  • @frissdiegurke Doesn't npm install nodebb-plugin-emoji still work? Rather than going through the ACP.

    EDIT: Having said that, the plugin hasn't been updated in about 12 months, so the chances of it being compatible with 0.6.x is quite slim. 😆

  • Plugin & Theme Dev

    @a_5mith said:

    @frissdiegurke Doesn't npm install nodebb-plugin-emoji still work? Rather than going through the ACP.

    It does. But the way through ACP is of cause more simple for NodeBB novices. Btw, it's emoji-extended that we're talking about (within your code it's emoji), so lets stop talking here 😄 rather than here for any further questions.

  • @frissdiegurke Ah, Extended definitely works if you run the npm command. I'm running it without issue.

  • Hello guys,

    Sorry for the trouble but I'm afraid I'm having an issue with this Emoji Plugin for a while now.
    I thought the mistake was on my end but as soon as I update my Nodebb, I try to give it a go again in case a fresh update would help me figure out what's going wrong. But I'm not getting close to a solution yet.

    So as soon as I activate this plugin (v 2.2.5) I have issues with undefined characters in the composer.

    For instance, if someone types in c'est (French word) it will come out in the preview panel and once posted as c undefined est same for ... becoming undefined.

    As soon as I deactivate the plugin and restart nodebb this behaviour stops.
    Do you have an idea why this is happening?


    0_1537648501879_PMU   Le café des sports   WotW.png

  • GNU/Linux Admin

    Make sure all you have enabled are emoji and the emoji pack. So for example:

    • nodebb-plugin-emoji, and
    • nodebb-plugin-emoji-android

    Make sure nodebb-plugin-emoji-extended is not activated!!

  • Global Moderator Plugin & Theme Dev

    @TaLoche I can't reproduce that issue. What version of the emoji plugin do you have?

    If you turn off the plugin settings in the ACP (ascii characters and native emoji) does it still happen?

    Can you copy the HTML of that post and paste it here?

  • Hi @julian and @PitaJ , thanks for your replies!

    I didn't know I had to install emoji-android, for example, as well.
    I thought that with only nodebb-plugin-emoji that was enough for me, since I only wanted to add custom emojis through the ACP and maybe later on create my own plugin emoji pack.

    So indeed if I add the emoji-android plugin the issue disappears. But the android pack has too many emojis, I only need the ones we've been using since 15 years. So I guess I'll have to take down all emoji plugins, set up mine then activated nodebb-plugin-emoji and my emoji pack to avoid those undefined mistakes.

    Would be great if later on we could only use nodebb-plugin-emoji and set up custom emojis from there without needing another emojis pack.
    And it would be also great to be able to add tabs there in order to sort out the custom emojis we are adding. But I know I'm asking for a lot.

    @julian I didn't have the nodebb-plugin-emoji-extended activated since I saw it wasn't supported anymore.

    @PitaJ I tried turning off both options in the ACP to see if it would change anything but it didn't unfortunately.
    As soon as I install the plugin, build assets in order to be able to see the Emoji options in the ACP and restart, I have this 'undefined' issue.
    For the html this is what I have for this post

    0_1537705756820_TF2   le rendez vous des collectionneurs de chapeaux   WotW.png


    Last question, on the nodebb-plugin-emoji, in the ACP what's the difference between where we can add 'Custom Emoji' and the bottom option 'Custom Extensions'. Sorry, I don't get the difference, and I've been adding custom extensions, rebuilding, restarting, build assets again but nothing changes when I add something there.

    Sorry for being such a pain!


  • Global Moderator Plugin & Theme Dev

    @TaLoche custom extensions are justa way to add new aliases and ascii patterns for existing emoji (like ones from a pack). I'll see if I can reproduce this with all emoji packs disabled.

  • @PitaJ ok got it! Thanks a lot.

  • Global Moderator Plugin & Theme Dev

    Ok I've just published emoji v2.2.6, it should make it possible to run without a pack active.

    You can try it by running npm install [email protected] in your NodeBB directory, and then rebuilding and restarting NodeBB.

  • @PitaJ You're the man! Thanks again for the quick reply and help!

  • Is there a way for personalized emoji to come first?

    For example, in the "custom" package, it goes much further back

    I would like it to appear first as an option for emojis

    I leave capture


  • Global Moderator Plugin & Theme Dev

    @arranka there's no setting for it, but if you'd like this added as a feature, open an issue on the GitHub page.

  • It looks also good if we can remove the 'legal information'

  • @sharonyue por favor diga su propuesta en el repositorio github
    le dejo el enlace


    It would be nice to be able to order personalized emojis in order of importance

    today by default they are in order by date

    So we could put the most important first and the least important at the end

  • @arranka said in [nodebb-plugin-emoji] Emoji Plugin:

    Is there a way for personalized emoji to come first?

    For example, in the "custom" package, it goes much further back

    I would like it to appear first as an option for emojis

    I leave capture


    Esto ya funciona con la nueva version

    muchas gracias

  • GNU/Linux


    I'm a bug with new version 😧

    2020-05-07T19:21:41.133Z [4567/12903] - warn: [plugins] Unable to parse library for: nodebb-plugin-emoji
    2020-05-07T19:21:41.133Z [4567/12903] - error: /srv/nodebb/node_modules/fs-extra/lib/mkdirs/make-dir.js:86
          } catch {
    SyntaxError: Unexpected token {
        at createScript (vm.js:80:10)
        at Object.runInThisContext (vm.js:139:10)
        at Module._compile (module.js:617:28)
        at Object.Module._extensions..js (module.js:664:10)
        at Module.load (module.js:566:32)
        at tryModuleLoad (module.js:506:12)
        at Function.Module._load (module.js:498:3)
        at Module.require (module.js:597:17)
        at require (internal/module.js:11:18)
        at Object.<anonymous> (/srv/nodebb/node_modules/fs-extra/lib/mkdirs/index.js:3:44)

Suggested Topics

  • 2
  • 8
  • 1
  • 40
  • 3
| |