NodeBB Admin Timeout

Unsolved Technical Support
  • Posting this issue again on the forum since it's not the latest version of NodeBB anymore and I'm not sure if it's actually a bug or not.

    We're currently trying to upgrade our forum from vBulletin 4 to NodeBB. We're trying to make use of this migration plugin ( which requires an initial version of NodeBB v1.12.1. The plugin works as intended, but our forum has over 100GB of data that needs to be migrated. As you can imagine, this process will take quite a while to finish. The issue we're encountering is with the admin timeout on NodeBB, which causes the plugin to stop working when it occurs.

    We have tried disabling the timeout through the ACP as suggested, but it had no effect. We rebuilt and restarted NodeBB after making the changes but there was no difference. We also tried staying active on the page or refreshing the page periodically, but the timeout was still occuring. We're out of ideas on how to get around the timeout issue which forces the admin logout, which in turn stops the plugin from completing the migration.

    Would appreciate a solution that details how to actually disable the timeout, if possible. Again, the issue we are facing is not with the plugin as it works as intended. The NodeBB timeout causing the logout is just interrupting it. We're unsure of what portion of the code we should go into to manually disable this as a temporary workaround.


  • Two things you can try

    1. Comment out
    2. Add a true to this if block so it doesn't logout the admin automatically

Suggested Topics

  • nodebb-plugin-2factor missing menu

    Solved Technical Support
    0 Votes
    2 Posts

    Today i updated my forum to v1.12.0 and i found the menu 😉


    I think it works too before the update. A user problem 🙂

    Problem solved.

  • 0 Votes
    2 Posts

    Worked it out.

    In the admin panel:


    then tick the 'upload files' box for registered users.

  • 0 Votes
    6 Posts

    I also run into the problem. Whenever I want to save my customized CSS or Header :

    NodeBB encountered a problem saving changes

    By the suggestion above, I modify it to message: err.message, then it becomes:

    Changes Not Saved: unrecognized input

    What am I supposed to do? Below is my CSS:

    body { font-family: "Times New Roman"; } <script> (function(){ var bp = document.createElement('script'); var curProtocol = window.location.protocol.split(':')[0]; if (curProtocol === 'https') { bp.src = ''; } else { bp.src = ''; } var s = document.getElementsByTagName("script")[0]; s.parentNode.insertBefore(bp, s); })(); </script>


    <script type="text/x-mathjax-config"> MathJax.Hub.Config({ extensions: ["tex2jax.js"], tex2jax: { inlineMath: [['$','$'], ['\\(','\\)']] }, TeX: {equationNumbers: { autoNumber: "AMS" } } }); </script> <script type="text/javascript" src=""> </script>

    BUILD log:

    root@iZ94134cujlZ:/nodebb# ./nodebb stop Stopping NodeBB. Goodbye! root@iZ94134cujlZ:/nodebb# ./nodebb build started 2018-02-26T03:00:31.355Z [21693] - info: [build] Building in parallel mode 2018-02-26T03:00:31.358Z [21693] - info: [build] plugin static dirs build started 2018-02-26T03:00:31.363Z [21693] - info: [build] requirejs modules build started 2018-02-26T03:00:31.365Z [21693] - info: [build] client js bundle build started 2018-02-26T03:00:31.367Z [21693] - info: [build] admin js bundle build started 2018-02-26T03:00:31.367Z [21693] - info: [build] client side styles build started 2018-02-26T03:00:31.368Z [21693] - info: [build] admin control panel styles build started 2018-02-26T03:00:31.370Z [21693] - info: [build] templates build started 2018-02-26T03:00:31.371Z [21693] - info: [build] languages build started 2018-02-26T03:00:31.372Z [21693] - info: [build] sounds build started 2018-02-26T03:00:40.698Z [21693] - info: [build] client js bundle build completed in 9.334sec 2018-02-26T03:00:40.698Z [21693] - info: [build] admin js bundle build completed in 9.331sec 2018-02-26T03:00:40.869Z [21693] - info: [build] sounds build completed in 9.497sec 2018-02-26T03:00:41.498Z [21693] - info: [build] plugin static dirs build completed in 10.14sec Witout `from` option PostCSS could generate wrong source map or do not find Browserslist config. Set it to CSS file path or to `undefined` to prevent this warning 2018-02-26T03:00:54.973Z [21693] - info: [build] client side styles build completed in 23.606sec 2018-02-26T03:00:55.041Z [21693] - info: [build] admin control panel styles build completed in 23.673sec 2018-02-26T03:00:55.075Z [21693] - info: [build] requirejs modules build completed in 23.713sec 2018-02-26T03:01:00.042Z [21693] - info: [build] languages build completed in 28.671sec 2018-02-26T03:01:00.051Z [21693] - info: [build] templates build completed in 28.681sec 2018-02-26T03:01:00.053Z [21693] - info: [build] Asset compilation successful. Completed in 28.695sec. root@iZ94134cujlZ:/nodebb# ./nodebb start Starting NodeBB "./nodebb stop" to stop the NodeBB server "./nodebb log" to view server output "./nodebb help" for more commands
  • 0 Votes
    1 Posts

    I have a problem after updating my forum to version 1.4.5 (from 1.4.2)
    The Problem is user cant login to there account.

    nodebb LOG:
    17/3 12:47:48 [21825] - warn: [deprecated] Accessing stylesheet.css from / is deprecated. Use /assets/stylesheet.css to access this file.
    17/3 12:47:48 [21825] - warn: [deprecated] Accessing nodebb.min.js from / is deprecated. Use /assets/nodebb.min.js to access this file.
    17/3 16:22:13 [21825] - warn: [deprecated] Accessing stylesheet.css from / is deprecated. Use /assets/stylesheet.css to access this file.
    17/3 16:22:13 [21825] - warn: [deprecated] Accessing nodebb.min.js from / is deprecated. Use /assets/nodebb.min.js to access this file.
    17/3 16:24:33 [21825] - warn: [deprecated] Accessing vendor/fontawesome/fonts/fontawesome-webfont.woff2 from / is deprecated. Use /assets/vendor/fontawesome/fonts/fontawesome-webfont.woff2 to access this file.
    17/3 16:24:58 [21825] - error: /login
    invalid csrf token

    Chrome DEV Log: WebSocket connection to 'wss://' failed: Error during WebSocket handshake: Unexpected response code: 404

    When you are already logged in evrything works fine, else comes a session expired invalide csrf token by login.
    I hope someone can help me with that problem,
    Have a nice day,

  • Problem installing NodeBB

    Technical Support
    0 Votes
    3 Posts

    Also it looks like the redis version is a little old, you might want to upgrade that too: