Problem initializing sounds?

General Discussion
  • Hi,

    Can anyone tell me what could be causing this error? Users have reported to me that they no longer hear notification sounds. I think it has something to do with this. My guess would be that the CHMOD value is not high enough, although I've tried increasing the values up to 777.

    {"level":"error","message":"Could not initialise sound files:EACCES, unlink '/home/nodebb/foorum/public/sounds/notification.mp3'","timestamp":"2014-05-21T17:40:24.532Z"}
  • @markkus Can you also double-check that the entire folder tree is owned by the same user running NodeBB? For example, even if notification.mp3 is owned by you (with 777 permissions), if you don't have read access to the parent directory, it might still not work.

    The sounds themselves are in node_modules/nodebb-plugin-soundpack-default, so try resetting the permissions on the entire folder. If you run it under the user markkus:

    $ cd /home/nodebb/foorum
    $ chmod -R markkus:markkus node_modules/
  • @julian Hmm... That does not seem to do the trick. The chmod value starting from nodebb-plugin-soundpack-default is set to 777. The parent directory node_modules is set to 775 (I'd doubt there would be anything different if it were 777). However the error does not seem to pop up in the error.log, although I can't hear the sounds, even when testing from ACP.
    Btw, the proper command to reset the permissions to the user would be:

    $ chown markkus:markkus node_modules -R 😄

  • Whoops, chown chmod.. same difference, right? 😆

    Do the sounds work in another browser? Any errors in console when you try playing the sound in the ACP?

Suggested Topics