Solved New Install - Plugin Page Freezes

  • @dunlix said in New Install - Plugin Page Freezes:

    @sampo2910 if your on Ubuntu you could look in the resource monitor.
    Also I didn’t read every post but if your hanged page problem is till a problem then start NodeBB using ./nodebb dev && ./nodebb log In the folder and send the logs here

    I am running Ubuntu 20.04

    I cannot kill nodebb. I have tried with PID ./nodebb stop does not work and so when i try and use ./nodebb dev it tells me nodebb is already running. Here is the full log on Google Drive. I cannot attach anything here.

  • GNU/Linux Gamers

    @sampo2910 if your on Ubuntu try looking for NodeBB on the recourse monitor app and ending it manually like task manager on windows. That way you can kill the “rogue process” and not all node.JS things.
    Stop NodeBB before ./nodebb dev because this just starts NodeBB in dev mode

  • Community Rep

    @sampo2910 Perhaps this may help?

    man pkill
     pgrep, pkill - look up or signal processes based on name and other attributes....

    Then you should be able to identify and kill all nodejs nodebb processes. You will likely want to send a SIGTERM, a.k.a. 15 numerically:

     kill -l
     1) SIGHUP       2) SIGINT       3) SIGQUIT      4) SIGILL       5) SIGTRAP
     6) SIGABRT      7) SIGBUS       8) SIGFPE       9) SIGKILL     10) SIGUSR1
    11) SIGSEGV     12) SIGUSR2     13) SIGPIPE     14) SIGALRM     15) SIGTERM
    16) SIGSTKFLT   17) SIGCHLD     18) SIGCONT     19) SIGSTOP     20) SIGTSTP
    21) SIGTTIN     22) SIGTTOU     23) SIGURG      24) SIGXCPU     25) SIGXFSZ
    26) SIGVTALRM   27) SIGPROF     28) SIGWINCH    29) SIGIO       30) SIGPWR
    31) SIGSYS      34) SIGRTMIN    35) SIGRTMIN+1  36) SIGRTMIN+2  37) SIGRTMIN+3
    38) SIGRTMIN+4  39) SIGRTMIN+5  40) SIGRTMIN+6  41) SIGRTMIN+7  42) SIGRTMIN+8
    43) SIGRTMIN+9  44) SIGRTMIN+10 45) SIGRTMIN+11 46) SIGRTMIN+12 47) SIGRTMIN+13
    48) SIGRTMIN+14 49) SIGRTMIN+15 50) SIGRTMAX-14 51) SIGRTMAX-13 52) SIGRTMAX-12
    53) SIGRTMAX-11 54) SIGRTMAX-10 55) SIGRTMAX-9  56) SIGRTMAX-8  57) SIGRTMAX-7
    58) SIGRTMAX-6  59) SIGRTMAX-5  60) SIGRTMAX-4  61) SIGRTMAX-3  62) SIGRTMAX-2
    63) SIGRTMAX-1  64) SIGRTMAX    

    You should be able to do this as your nodebb user, i.e. nodebb process owner. Else of course doing so as root will also get the job done.

  • Global Moderator Plugin & Theme Dev

    @sampo2910 please try killing all node processes as described in this thread:

    And do so as root

  • I tried using the system monitor to kill all node processes. These are the ones running and their path. But if i kill them all I can still see the webpage.


    This is results of ./nodebb log:

    [email protected]:~/nodebb$ ./nodebb log
    Hit Ctrl-C to exit

    [cluster] Child Process (43554) has exited (code: null, signal: SIGKILL)
    [cluster] Spinning up another process...
    2021-09-27T22:00:56.577Z [4567/43574] - info: Initializing NodeBB v1.18.3 http://localhost:4567
    2021-09-27T22:00:57.940Z [4567/43574] - info: [] Restricting access to origin: http://localhost😘
    2021-09-27T22:00:58.166Z [4567/43574] - info: [plugins/spam-be-gone] Settings loaded
    2021-09-27T22:00:58.184Z [4567/43574] - info: [api] Adding 0 route(s) to api/v3/plugins
    2021-09-27T22:00:58.196Z [4567/43574] - info: [router] Routes added
    2021-09-27T22:00:58.198Z [4567/43574] - info: NodeBB Ready
    2021-09-27T22:00:58.199Z [4567/43574] - info: Enabling 'trust proxy'
    2021-09-27T22:00:58.201Z [4567/43574] - info: NodeBB is now listening on:

    It is hard to know what the rogue process is?? What should i kill...?
    Are their two instances running here or something? Am i on wrong port or something. No idea . Is it conflicting with another node app?

  • If I end or kill any other process from system monitor it disappears from list.

    Node just keeps reappearing in the list. Web page is still there etc.

    Also nodebb is starting itself after I reboot the machine. So as a service? I never set that up. But.....I did do that a long time ago on another installation (or tried- it did not work)

  • Soon as it is stopped it starts again in 2 seconds on another PID.


  • Community Rep

    @sampo2910 You need to ensure that you are killing all running nodebb processes simultaneously. I do not manage my servers via gui's so only familiar with cli driven tools.

    And since at this juncture who knows who may own them, like pitaj suggests above, you may well need to be root. 🐕

    P.S.; Do you have ANY other nodejs apps running on the box? If NOT then kill ALL nodejs processes.

  • @gotwf

    I normally use terminal but that failed so tried my GUI also. I really never go there but can access from my windows monitor if needed.

    I have one other node app running (it is ok to kill that for now too) but I have tried and with with sudo also.

    I left the browser open after clicking on 'find plugins' it was spinning and spinning and after about 8 minutes the page appeared. I then was actually then able to install a plugin form it !

    I really have no idea what is going on. I can only think that something is wrong from a previous installation and that something was left behind somewhere. Next option is format and reinstall OS. But....dont want to go down that road just for the sake of one page not loading. But something is definitely not right of course 🙂

  • Global Moderator Plugin & Theme Dev

    @sampo2910 yeah it sounds like you definitely have a service running. What OS are you using?

  • @pitaj yes I checked service is definitely running.

    Using 20.04. I’m thinking that is this really going to be an issue in the future and need sorting now ? Or something I can leave ?

    As I said the forum works fine and can navigate all over other than the going to extend- plugins and ‘find plugins’ tab and going to ‘install plugins’ last option from main plugins tab.

  • GNU/Linux Gamers

    @sampo2910 try

    sudo systemctl stop nodebb.service

  • @dunlix ' try sudo systemctl stop nodebb.service'

    This worked. I can go into dev mode no problem now. But when I go to plugins it still freezes.

    What can i now do to clear this rogue process that we talked about? If any.

    Waiting about 5 mins and the page finally appears...but that was same yesterday. So now we know how to kill it but still no change with problem.

    Could it be something to do with NGINX VHost or config.json ? I noticed when I installed a discord notification worked..but the link on the discord server was to localhost. config.json url was wrong and not on my forum url. I changed that and fixed. Plugin freeze is still the same.

  • After clicking the tab and two coffees later the page is there. So it is not 'blocked' or restricted I guess.

    So why is it hanging and freezing and then sometimes appearing after 2 coffees 🙂 haha

    plugins page.png

  • Community Rep

    @sampo2910 said in New Install - Plugin Page Freezes:

    @dunlix ' try sudo systemctl stop nodebb.service'
    This worked. I can go into dev mode no problem now. But when I go to plugins it still freezes.

    Holy, holy, guacamole! 🥑 🤦

    Kudos to @dunlix for explicitly stating the obvious. 👍

  • NodeBB

    Does your database have indices?
    Check with db.objects.getIndexes().
    Find plugins page loads pretty fast on this forum and my local.

  • Global Moderator Plugin & Theme Dev

    @sampo2910 you can do sudo systemctl disable nodebb to turn off the service and it shouldn't restart automatically like it has.

    That was the rogue process so you've taken care of it.

    As for the plugins page, is it still hanging your browser out is it just taking a long time to load?

  • @pitaj Is it not better to have it run as a service so you don’t need to start each time the Server reboots ?

    How is that the rogue service?

    At the moment the page still hangs….

  • Community Rep

    @pitaj said in New Install - Plugin Page Freezes:

    @sampo2910 you can do sudo systemctl disable nodebb to turn off the service and it shouldn't restart automatically like it has.

    @sampo2910 said in New Install - Plugin Page Freezes:

    @pitaj Is it not better to have it run as a service so you don’t need to start each time the Server reboots ?

    Generally for production use, yes. This is testing and dev use, however, so better to disable now as pitaj recommends above, debug, and then re-enable when you're ready transition to production.

    In the meantime, since will be in test and dev use you will likely have your fingers in the box as a matter of course. So then easier to start manually from cli w/logs to console for real time "observablility". 🐕

  • So thanks to @dunlix for letting us 'know' what we probably did already know but forgotten 🙂 i.e. : sudo systemctl stop nodebb.service

    I have also done as @PitaJ recommended and disabled the service. As you say @gotwf fingers in a box and not so bad just to start manually after a reboot.

    The page is still hanging/freezing but I guess after this huge thread 🙂 it is something I am going to have to live with.

Suggested Topics

| |