SOLVED New Install - Plugin Page Freezes

  • Global Moderator Plugin & Theme Dev

    Ah looks like there's a client side JavaScript infinite loop for some reason. What browser are you using?

    Have you tried a different browser?


  • @pitaj as said above multiple browsers. But this was not like this before.

    I have set up the forums again. All no problem navigating, widgets, other plugins.

    But going to extend-plugins-find plugins..FREEZE.

    Also this way plugins-install-plugins FREEZE

    So basically I need to set up the email because I need to install a plugin?? Which i cannot.

    ERROR
    The sendmail executable could not be found, please ensure it is installed and executable by the user running NodeBB.


  • @sampo2910 interesting. I experienced this exact same error message when suddenly my forum would no longer run as daemon.


  • @phenomlab I have just noticed that all is fine ONLY on MS Edge browser I had tried firefox and opera and no good......I am going to uninstall chrome and reinstall and see whats what....If still no good I will have to use edge ( i dont want to)


  • @sampo2910 want to DM me the URL and login ? I can test from here also meaning we can validate if it's a NodeBB issue or not.

  • Global Moderator Plugin & Theme Dev

    @sampo2910 you don't need a plugin for email. You can use the built in SMTP option instead.

    I'll see if I can reproduce.


  • @pitaj I don't use Sendmail either but for the same message when my site suddenly stopped working as daemon. Wondering if there's any parallel here.

  • Global Moderator Plugin & Theme Dev

    @phenomlab I doubt that sendmail has anything to do with the plugin page hanging the browser.

    @Sampo2910 I haven't been able to reproduce yet on Firefox 92.0 or Chromium 92.0 on Linux. What version of Firefox are you using? You're on NodeBB 1.18.3 right?


  • @pitaj Well it is not working with default built in then.

    I input my smtp settings and that was the problem i got. Those smtp settings worked previously.

    And update again...It is NO LONGER WORKING ON MS Edge. Just tried again.

    No idea what this is.

    This was in logs regarding email:

    Error: The sendmail executable could not be found, please ensure it is installed and executable by the user running NodeBB.
    at Emailer.sendToEmail (/home/smiley/nodebb/src/emailer.js:337:10)
    at runMicrotasks (<anonymous>)
    at processTicksAndRejections (internal/process/task_queues.js:95:5)
    at async Emailer.send (/home/smiley/nodebb/src/emailer.js:259:2)
    at async UserEmail.sendValidationEmail (/home/smiley/nodebb/src/user/email.js:134:3)
    at async Email.test (/home/smiley/nodebb/src/socket.io/admin/email.js:37:4)
    at async onMessage (/home/smiley/nodebb/src/socket.io/index.js:164:19)


  • @pitaj true, but I'm curious to know if the forum actually crashes when this message is generated.

  • Global Moderator Plugin & Theme Dev

    @sampo2910 did you set up the built in SMTP emailer? You have to enable it and provide account details.

    Is your forum available publicly? Have you tried a different computer?


  • @pitaj Firefox was a test. I dont use it. I just downloaded the latest to try it. I use latest version as Chrome by default.

    But whatever browser I use it is the same. Problem must lie elsewhere.

    Regarding email and saying dont need to install anything why is that in the logs

    'The sendmail executable could not be found, please ensure it is installed and executable ' Permissions? And can i get 1 reputation point please lol....I have to keep waiting to post 🙂

    The forum does not crash when it is hanging...I have to close the page wait a minute and then go in again. It is only that 'find plugins page' NO WHERE else.

    SMTP settings have all the account details all set up. Like i said it worked before.

  • Community Rep

  • Global Moderator Plugin & Theme Dev

    @sampo2910 sendmail isn't necessary if you have SMTP set up. I just checked. If you share a screenshot of your emails settings page I can help you more.

    That's a different issue we can figure out later though. Let's focus on the problem at hand. You haven't really been answering my questions, please answer all questions I ask or I won't have enough information to help you.

    • Are you on NodeBB 1.18.3?
    • Is your forum available through the internet?
    • Have you tried using a different computer?
  • Community Rep

    @pitaj Well, from the error it would seem OP was trying to utilize the sendmail executable rather than the built-in, no? Which I presumed was purposeful since I don't think that is default? 🤔

  • Global Moderator Plugin & Theme Dev

    @gotwf sendmail is default if SMTP is not enabled. (which it by default is not)

  • Community Rep

    @pitaj "sendmail" the builtin nodejs stuff or "sendmail" the executable, as in Postfix drop in replacement? Postfix made things easy to replace Sendmail, the defacto default executable bitd in that regard but using the same name has led to confusion a time or two... Heck, I am not even sure I was clear enough in that howto. Maybe I need to reword some of that? 🤔

    I think you are using "sendmail" to reference the NodeBB built in. Just to clarify for those who may come to this thread later. 🐕 ✌

  • Global Moderator Plugin & Theme Dev

    @gotwf "sendmail" is an executable on your system. By default (when SMTP transport is disabled and there is no emailer plugin installed), NodeBB uses a sendmail transport provided by the nodemailer package. The sendmail transport will call the sendmail executable on the system, if it exists.

    I'm not referring to some NodeBB internal system. Generally we call the system in NodeBB which handles sending emails the "emailer".

  • Community Rep

    @pitaj Hmm... Does Debian still ship with Exim by default? Does Exim rename their executable to sendmail? I'd thought not but been a while since I used it. I think OP is using Ubuntu (wh/includes Postfix's sendmail executable as shipped). But they maybe on Deb? Just to clarify.

    Qmail would be another example of a Sendmail daemon replacement. Qmail executable is "qmail". Once upon a time pretty much the defacto replacement for Sendmail. Qmail does not call its executable "sendmail".

    Hence, although Postfix has evolved as the MTA of choice over the past couple decades it is not the only option. Options which do not rename their MTA binaries so maybe probing/checking for "sendmail" could be less than robust?

    Edit: Yeah, Debian does still include Exim by default https://wiki.debian.org/Exim


  • @pitaj said in New Install - Plugin Page Freezes:

    @sampo2910 sendmail isn't necessary if you have SMTP set up. I just checked. If you share a screenshot of your emails settings page I can help you more.

    That's a different issue we can figure out later though. Let's focus on the problem at hand. You haven't really been answering my questions, please answer all questions I ask or I won't have enough information to help you.

    • Are you on NodeBB 1.18.3?
    • Is your forum available through the internet?
    • Have you tried using a different computer?

    The very first time i set up nodebb i never had this issue at all. I have done same again...(this is 5th time to be sure) but this. Like i said all is fine on whole admin site apart from these two things. Freeze and Mail.

    Yes
    Yes
    Yes

    emailpage.png

Suggested Topics

| |