[Solved] login not possible

Bug Reports
  • Hi,
    i have an issue with my nodebb setup.
    I did a fresh archlinux installation on my raspberry pi.

    At first i copied an existing nodebb forum v0.4.2(about 300 posts) on my raspberry.
    I am quite impressed by the performance on the 700mhz/512mb box. 👍
    But i cannot login, when i try to login the cpu load goes up to 100% for 3-4minutes, and nothing happens.
    -> no login -> no error in nodebb log

    I thought the problem is the existing nodebb forum.
    So i did a fresh nodebb setup. -> same problem, cpu load 100% for 3-4minutes,
    but at least i get an error message, "pssword not correct".
    but the password is correct, i tried it twice.

    In the logs i get one warning. "Couldn't find convert. Did you install imagemagick?"
    But ImageMagick is installed.
    "which convert" returns /usr/bin/convert

    • python 2.7.6
    • nodejs 0.10.28
    • node-gyp 0.13.0
    • redis 2.8.9
    • ImageMagick 6.8.9-1
  • Hi @fredrik -- for Raspberry Pi, please do the following:

    1. Uninstall bcryptjs: npm unlink bcryptjs
    2. Install bcrypt: npm i bcrypt
    3. At the top of the following files, change require('bcryptjs'); to require('bcrypt');:
      • /src/routes/authentication.js
      • /src/user.js
      • /src/user/profile.js

    Similar to Ghost installs: http://c-mobberley.com/wordpress/2014/01/30/raspberry-pi-ghost-blog-slow-login-sign-up-fix/

  • thank you very much 😄 it works

Suggested Topics