SOLVED - EACCES errors after rebuilds

Unsolved Technical Support
  • This mailer and emoji problem seem to come up every now and then but I lost track if it's only when I upgrade. Is there anything to be concerned about?

    2021-07-24T00:21:03.685Z [4567/2098] - error: [emailer] Failed to build custom email templates
    Error: EACCES: permission denied, open '/opt/nodebb/build/public/templates/emails/banned.js'
    2021-07-24T00:21:04.042Z [4567/2098] - error: [plugins] Error executing 'static:app.load' in plugin 'nodebb-plugin-emoji'
    Error: EACCES: permission denied, unlink '/opt/nodebb/node_modules/nodebb-plugin-emoji/build/emoji/aliases.json'
    2021-07-24T00:21:04.074Z [4567/2098] - info: [api] Adding 0 route(s) to `api/v3/plugins`
    2021-07-24T00:21:04.101Z [4567/2098] - info: [router] Routes added
    2021-07-24T00:21:04.111Z [4567/2098] - info: NodeBB Ready
    2021-07-24T00:21:04.113Z [4567/2098] - info: Enabling 'trust proxy'
    2021-07-24T00:21:04.116Z [4567/2098] - info: NodeBB is now listening on:
  • Sounds like you probably used root/sudo to install or run NodeBB at one point. You probably need to chown the folder to the user you run NodeBB with.

  • @pitaj Hi, I changed the owner when first installing a month or more ago but I've seen these errors come and go. The owner is nodebb.nodebb based on a document I was following when first installing.

    I do see the is owned by root. In fact, I see a few files here and there which are owned by root including the install folder.

    It's possible I ran some things as root while struggling with the conversion.
    Should I chown everything back to nodebb now and then?

    UPDATE: I chown everything back to nodebb and restarted the board and no errors. Simple fix. Thank you.

Suggested Topics