SOLVED Error On Install -Please Please Help - Losing The Will To Live

  • GNU/Linux

    Hey buddy šŸ™‚
    Did you follow the instructions on https://docs.nodebb.org/installing/os/ubuntu/ ?

    It looks to me like the required softwares are not updated.


  • @atayz Hi thx for the reply. Yes i followed that and have updated. I can start the forum in dev mode but not startup normally.

    I have this in dev mode:

    smiley@fmjcod4:~/nodebb$ ./nodebb dev

    NodeBB v1.7.5 Copyright (C) 2013-2014 NodeBB Inc.
    This program comes with ABSOLUTELY NO WARRANTY.
    This is free software, and you are welcome to redistribute it under certain conditions.
    For the full license, please visit: http://www.gnu.org/copyleft/gpl.html

    Clustering enabled: Spinning up 1 process(es).

    2021-07-10T16:25:34.933Z [11405] - info: Initializing NodeBB v1.7.5 https://forum.fmjcod4.com
    2021-07-10T16:25:34.934Z [11405] - verbose: * using mongo store at 127.0.0.1:27017
    2021-07-10T16:25:34.934Z [11405] - verbose: * using themes stored in: /home/smiley/nodebb/node_modules
    [benchpressjs] Unable to build or find a suitable native module, falling back to JS version
    2021-07-10T16:25:35.635Z [11405] - verbose: [minifier] utilizing a maximum of 3 additional threads
    2021-07-10T16:25:35.646Z [11405] - verbose: Checking dependencies for outdated modules
    2021-07-10T16:25:35.850Z [11405] - verbose: [notifications.init] Registering jobs.
    2021-07-10T16:25:35.850Z [11405] - verbose: [user/jobs] (Re-)starting user jobs...
    2021-07-10T16:25:35.851Z [11405] - verbose: [user/jobs] Starting job (digest.daily)
    2021-07-10T16:25:35.853Z [11405] - verbose: [user/jobs] Starting job (digest.weekly)
    2021-07-10T16:25:35.854Z [11405] - verbose: [user/jobs] Starting job (digest.monthly)
    2021-07-10T16:25:35.854Z [11405] - verbose: [user/jobs] Starting job (reset.clean)
    2021-07-10T16:25:35.854Z [11405] - verbose: [user/jobs] 4 jobs started
    2021-07-10T16:25:35.854Z [11405] - verbose: [emailer] Setting up SMTP fallback transport
    2021-07-10T16:25:35.894Z [11405] - verbose: [emailer] Built custom email templates
    2021-07-10T16:25:35.895Z [11405] - info: [themes] Using theme nodebb-theme-persona
    2021-07-10T16:25:35.895Z [11405] - verbose: [plugins] Initializing plugins system
    2021-07-10T16:25:35.900Z [11405] - verbose: [plugins] Loaded plugin: nodebb-plugin-composer-default
    2021-07-10T16:25:35.901Z [11405] - verbose: [plugins] Loaded plugin: nodebb-theme-persona
    2021-07-10T16:25:35.916Z [11405] - verbose: [plugins] Loaded plugin: nodebb-plugin-markdown
    2021-07-10T16:25:35.924Z [11405] - verbose: [plugins] Loaded plugin: nodebb-plugin-mentions
    2021-07-10T16:25:35.925Z [11405] - verbose: [plugins] Loaded plugin: nodebb-widget-essentials
    2021-07-10T16:25:35.927Z [11405] - verbose: [plugins] Loaded plugin: nodebb-rewards-essentials
    2021-07-10T16:25:35.928Z [11405] - verbose: [plugins] Found 3 sound file(s) for plugin nodebb-plugin-soundpack-default
    2021-07-10T16:25:35.928Z [11405] - verbose: [plugins] Loaded plugin: nodebb-plugin-soundpack-default
    2021-07-10T16:25:35.966Z [11405] - verbose: [plugins] Loaded plugin: nodebb-plugin-emoji
    2021-07-10T16:25:35.974Z [11405] - verbose: [plugins] Loaded plugin: nodebb-plugin-emoji-android

    2021-07-10T16:25:35.975Z [11405] - warn: [plugins/load] The following plugins may not be compatible with your version of NodeBB. This may cause unintended behaviour or crashing. In the event of an unresponsive NodeBB caused by this plugin, run ./nodebb reset -p PLUGINNAME to disable it.

    • nodebb-plugin-composer-default

    2021-07-10T16:25:35.975Z [11405] - info: [plugins] Plugins OK
    2021-07-10T16:25:36.005Z [11405] - verbose: [hotswap] Router with id plugins replaced successfully
    2021-07-10T16:25:36.005Z [11405] - verbose: [plugins] All plugins reloaded and rerouted
    2021-07-10T16:25:36.005Z [11405] - verbose: [hotswap] Router with id auth replaced successfully
    2021-07-10T16:25:36.005Z [11405] - info: Routes added
    2021-07-10T16:25:36.007Z [11405] - verbose: [meta/blacklist] Loading 0 blacklist rule(s)
    2021-07-10T16:25:36.007Z [11405] - info: NodeBB Ready
    2021-07-10T16:25:36.008Z [11405] - info: Enabling 'trust proxy'
    2021-07-10T16:25:36.009Z [11405] - info: NodeBB is now listening on: 0.0.0.0:4567

  • Global Moderator Plugin & Theme Dev

    Upgrade your Node version to 14.


  • @pitaj said in Error On Install -Please Please Help - Losing The Will To Live:

    Upgrade your Node version to 14.

    It is 14 šŸ˜ž

  • GNU/Linux

    @sampo2910 said in Error On Install -Please Please Help - Losing The Will To Live:

    2021-07-10T16:25:35.975Z [11405] - warn: [plugins/load] The following plugins may not be compatible with your version of NodeBB. This may cause unintended behaviour or crashing. In the event of an unresponsive NodeBB caused by this plugin, run ./nodebb reset -p PLUGINNAME to disable it.

    For some reason the log shows that nodebb-plugin-composer-default is incompatible.

    Run this:

    ./nodebb reset -p nodebb-plugin-composer-default
    

    And let me know if nodebb can start afterwards.


  • @sampo2910 what is the npm version?


  • @volanar npm -v 6.4.13

    @Atayz That seems to have cleared that error starting in dev but still cannot start normally. I get this.

    smiley@fmjcod4:~/nodebb$ ./nodebb start

    Starting NodeBB
    "./nodebb stop" to stop the NodeBB server
    "./nodebb log" to view server output
    "./nodebb help" for more commands

    smiley@fmjcod4:~/nodebb$ internal/fs/utils.js:793
    throw new ERR_INVALID_ARG_TYPE(
    ^

    TypeError [ERR_INVALID_ARG_TYPE]: The "data" argument must be of type string or an instance of Buffer, TypedArray, or DataView. Received type number (6794)
    at Object.writeFileSync (fs.js:1517:5)
    at /home/smiley/nodebb/loader.js:234:7
    at /home/smiley/nodebb/node_modules/graceful-fs/graceful-fs.js:352:16
    at FSReqCallback.oncomplete (fs.js:180:23) {
    code: 'ERR_INVALID_ARG_TYPE'
    }

  • Global Moderator Plugin & Theme Dev

    @sampo2910 in your original post it says it's version 8

    0 info it worked if it ends with ok
    1 verbose cli [ '/usr/bin/node', '/usr/bin/npm', 'install', '--production' ]
    2 info using npm@3.5.2
    3 info using node@v8.10.0
    

    So have you upgraded it? Please provide the output of ./nodebb info


  • @pitaj said in Error On Install -Please Please Help - Losing The Will To Live:

    @sampo2910 in your original post it says it's version 8

    0 info it worked if it ends with ok
    1 verbose cli [ '/usr/bin/node', '/usr/bin/npm', 'install', '--production' ]
    2 info using npm@3.5.2
    3 info using node@v8.10.0
    

    So have you upgraded it? Please provide the output of ./nodebb info

    Yes I updated it as suggested on another thread here and it had cleared some errors. Here is the out put of ./nodebb.info

    [benchpressjs] Unable to build or find a suitable native module, falling back to JS version

    version: 1.7.5
    Node ver: v14.17.3
    git hash: 87c5dd34ea0171ac295bbf3c8d73c68076bc5c57

    database: mongo
    version: 3.6.3
    engine: wiredTiger

  • Global Moderator Plugin & Theme Dev

    Didn't notice this before, but you installed NodeBB v1.7.5, was that on purpose? The latest version is 1.17.2


  • @pitaj said in Error On Install -Please Please Help - Losing The Will To Live:

    Didn't notice this before, but you installed NodeBB v1.7.5, was that on purpose? The latest version is 1.17.2

    I did not do on purpose ? Damn..can i update in terminal?


  • OK,

    I did ./nodebb update and the ./nodebb start and it page is there and running.

    Could someone send me a link or instruction how to keep it alive and start again if server reboots?

    My other app i do that with PM2. Can i do same with nodebb.

    Thank you all for the help. Huge appreciation.

  • Global Moderator Plugin & Theme Dev

    @sampo2910 ./nodebb update does not actually update your NodeBB version. You have to do that with git. I recommend starting over from scratch unless you've made a bunch of changes.


  • @pitaj

    I used git and I am on 17.2 now and all is ok...just getting my head around a few things now...:-)

    I would llike to know how to keep it alive even after a reboot now. šŸ™‚

  • Global Moderator Plugin & Theme Dev

Suggested Topics

  • 1
  • 20
  • 13
  • 15
  • 15
| |