SOLVED phpbb >nodebb, admin/mods cannot edit


  • No errors in the nginx or nodebb logs.
    No errors in inspector console either other than this which I've seen for other sites.

    This page uses the non standard property “zoom”. Consider using calc() in the relevant property values, or using “transform” along with “transform-origin: 0 0”.

    If I refresh the page, then it shows up in the nginx access lot. However, nothing is shown in the log when clicking on anything and Reply doesn't do anything either. I had not even tried that until now.

    Oddly, I can delete the copy of the posts. As mentioned above, the converter generated two copies of some of the comments in posts. One more thing that's interesting is that I deleted a comment as moderator for example but it still continues to show, grayed out and says '2 out of 2'

    It is even stranger that I can configure the board, change settings etc, but only when it comes to moderating posts, or at least, it's all I've noticed so far, it cannot be done.

  • Global Moderator Plugin & Theme Dev

    Generally you want to enable most of the installed plugins. I suggest going through the list and selecting each plugin that sounds like something you want/need.

    I'm not sure how they got disabled, it's certainly possible the importer did it. I don't know what exact steps you took to import your data.

  • Global Moderator Plugin & Theme Dev

    @freelancer you can PM me the url.

    @NodeHam please PM me the url of your site as well and I'll take a look


  • @nodeham said in phpbb >nodebb, admin/mods cannot edit:

    @macfan I'm not sure why you commented 'for sure' unless it's happening to you also but yes, same behavior.

    You just answered yourself mate 🙂


  • @macfan Sorry to hear it. It's been quite frustrating since people might post in the old forums before we get a chance to get the new one up making them out of sync.


  • @pitaj New to nodebb, not seeing a way to pm you, only chat you. I'll keep looking.

  • Global Moderator Plugin & Theme Dev

    @NodeHam had the composer plugin disabled so there was nothing to edit posts with. I enabled it and can now edit and create posts/topics.


  • @pitaj Thank you very much for helping on this. Just curious, is there a reason this plugin is disabled by default or did we disable it by accident?

    One odd thing is that there is html code stuck in the text when editing. When removing that, it makes the text one huge blob.

    I think I am missing another plugin that I've missed because of this initial problem. For example, none of the edit tools show when editing such as bold, code, etc.

    Not sure if you want me to ask these things here or back in the thread so it can help others.

  • Global Moderator Plugin & Theme Dev

    Generally you want to enable most of the installed plugins. I suggest going through the list and selecting each plugin that sounds like something you want/need.

    I'm not sure how they got disabled, it's certainly possible the importer did it. I don't know what exact steps you took to import your data.


  • @pitaj I found out what happened. During the conversion from phpbb, the dev had a bunch of problems and one of the things done was to disable all of the plugins. I believe there are some 15 installed but only one active which would probably answer why the text in the posts are all messed up.

    Is there a list somewhere that shows which plugins are enabled by default with a new install? I'm looking on the net for that but not finding anything. I would probably have to re-install a new nodebb to know this otherwise.

  • NodeBB


  • Thanks for the list of plugins. I re-enabled those but had to disable the markdown one as it definitely adds html code into the posts.

    I also found out since my last post that ./nodebb reset was used as part of the conversion from phpbb. I'm not sure I'll be able to make this live, it's too much of a mess. There is html code all over everything and it's in fact a mix of html and phpbb bb code I think it's called.


  • I will start a new thread for the other problems. Thank you very much for the help.


  • @nodeham try downloading the Quill Editor plugin to replace the default Markdown editor. Quill has an option to convert previously post into Quill format which might help remove the HTML tags. I have not tried it since I used Redact instead. Redact doesn't have that conversion option though.


  • @keng-her Thank you. I'll back everything up and try that and report back.

Suggested Topics

  • 6
  • 1
  • 13
  • 5
  • 7
| |