• Hello,
    15.03.2021 My host was reboot server and all virtual machines too. When VM was loaded, i was try to start site, i was wrote ./nodebb start, and i saw:

    root@darkshy:/var/www/html# ./nodebb start
    Starting NodeBB
      "./nodebb stop" to stop the NodeBB server
      "./nodebb log" to view server output
      "./nodebb help" for more commands
    

    But when i wrote ./nodebb log - i was take error:

    root@darkshy:/var/www/html# ./nodebb log
    
    Hit Ctrl-C to exit
    
    
        at runMicrotasks (<anonymous>)
        at processTicksAndRejections (internal/process/task_queues.js:93:5)
        at async onMessage (/var/www/html/src/socket.io/index.js:143:3)
    2021-03-14T16:54:55.474Z [4567/23981] - error: admin.getSearchDict
    Error: [[error:invalid-session]]
        at validateSession (/var/www/html/src/socket.io/index.js:196:9)
        at runMicrotasks (<anonymous>)
        at processTicksAndRejections (internal/process/task_queues.js:93:5)
        at async onMessage (/var/www/html/src/socket.io/index.js:143:3)
    

    After it, i was wrote ./nodebb stop, and take: NodeBB is already stopped.

    I dont know how to fix it. Please help. /_\


  • anybody know how to fix it?!
    HALP

  • NodeBB

    Check the memory usage on your server how much free ram does it have?


  • GNU/Linux Admin

    @dark-shy we'll need to see the full log. Please use less to view logs/output.log

  • Global Moderator Plugin & Theme Dev

    Also version of NodeBB, Node, database, os, etc

  • Community Rep

    Your vm may have suffered an unclean shutdown. Note "may". In absence of more info, a couple things to try.

    If you have nodebb set up to be launched via systemd, disable that. And then stop just for good measure and then disable dependencies:

    systemctl disable nodebb
    systemctl stop nodebb
    systemctl disable nginx (sub apache if using apache)
    systemctl disable mongod (or whatever db backend you're using
    
    

    Then reboot the vm. When it comes back up we're going to restart all that in reverse order, verifying each is up and running before proceeding to next:

    systemctl status mongod
    systemctl status nginx
    systemctl status nodebb
    

    Those should now all report "disabled". So let's start them up, verifying each launches w/o error before proceeding to next

    systemctl start mongod
    
    

    If the startup messages are greek to you or pass by too quickly:

    systemctl status mongod
    

    Should report something very close to this:

    [root@forums ~]# systemctl status mongod
    ● mongod.service - MongoDB Database Server
       Loaded: loaded (/usr/lib/systemd/system/mongod.service; enabled; vendor preset: disabled)
       Active: active (running) since Fri 2021-03-05 06:57:52 UTC; 1 weeks 6 days ago
         Docs: https://docs.mongodb.org/manual
      Process: 457777 ExecStart=/usr/bin/mongod $OPTIONS (code=exited, status=0/SUCCESS)
      Process: 457762 ExecStartPre=/usr/bin/chmod 0755 /var/run/mongodb (code=exited, status=0/SUCCESS)
      Process: 457739 ExecStartPre=/usr/bin/chown mongod:mongod /var/run/mongodb (code=exited, status=0/SUCCESS)
      Process: 457725 ExecStartPre=/usr/bin/mkdir -p /var/run/mongodb (code=exited, status=0/SUCCESS)
     Main PID: 457824 (mongod)
       CGroup: /system.slice/mongod.service
               └─457824 /usr/bin/mongod -f /etc/mongod.conf
               ‣ 457824 /usr/bin/mongod -f /etc/mongod.conf
    
    

    If that all looks good, try starting nodebb:

    systemctl start nodebb
    

    A status check should look something like this:

    [root@forums ~]# systemctl status nodebb
    ● nodebb.service - NodeBB
       Loaded: loaded (/etc/systemd/system/nodebb.service; enabled; vendor preset: disabled)
       Active: active (running) since Fri 2021-03-05 06:59:17 UTC; 1 weeks 6 days ago
         Docs: https://docs.nodebb.org
      Process: 459055 ExecStart=/usr/bin/env node loader.js (code=exited, status=0/SUCCESS)
     Main PID: 459071 (node)
       CGroup: /system.slice/nodebb.service
               ├─459071 /usr/bin/node /opt/nodebb/loader.js
               ├─459082 /usr/bin/node /opt/nodebb/app.js
    
    

    If you are getting anything other than "SUCCESS" then stop just be sure:

    systemctl stop nodebb
    
    

    Then sudo to change to your nodebb user and then go try starting nodebb manually using the "log" flag:

    cd /where/ever/your/nodebb/lives
    ./nodebb start -l
    

    Then copy/pasta the ensuing spewage so the other gurus in the lurking can deconstruct. Good luck.

    Once you get this sorted, be sure to re-enable those services else they will not automatically restart after a shutdown/reboot.

    systemctl enable mongod
    systemctl enable nginx
    systemctl enable nodebb
    

    I'd even then reboot after that just to be sure all comes back up as expected.

    Yeah, this is not issue specific but when dealing with unknown glitches it is nice to rule out some low hanging fruit to help isolate.

Suggested Topics

  • 14
  • 18
  • 4
  • 14
  • 2
| |