• @omega

    does the apple option work in your forum?

  • Global Moderator Plugin & Theme Dev

    @majr are you still having issues? Any errors in server logs or in the browser? Does the build emoji button complete successfully, showing a success message? What version of Node are you using?

  • Community Rep

    @MAJR @PitaJ

    Hey so I also ran the following in the cli just in case:

    npm upgrade nodebb-plugin-emoji


    ./nodebb upgrade-plugins

    Then finally,

    ./nodebb build

    I also update npm to version 7.5.3 > 7.5.4

    Things do seem more stable but I am not ready yet to pronounce it issue free. Give it 24/48 hours and a checking on few other devices later and I'll update.

  • Community Rep

    Nope this is still behaving strangely.

    I have seen a warning in the log about the emoji plugin not being compatible!

    Emojis present on first page load as broken images, a page refresh displays them. Navigate away and navigate back and they are broken again.

    The Build Emoji button has always completed successfully in my experience.

    Sometimes I try then also a full rebuild via the ACP. None of this seems to make a difference.

    Finally, I tried to create a custom emoji, while it saved, I had to buy;/restart to get it to appear int he selector panel.

    Tried a custom emoji, same deal, it appears as a broken image, refresh's and it's there. Nav away and back to page, all broken again.

    Maybe there is something at the nginx level that needs to be addressed.

  • @pitaj @omega

    I could not get it to work.
    I get error messages:
    When i install the ...android it says to require a peer of [email protected]^2.0.0 but none is installed
    I change it - No difference

    When I go for apple it says...requires a peer of [email protected]^3.4.2 but none is installed
    I change it - No difference

    I also have this message but I do not know what it means ???:
    BEGIN emojis -->
    | ^^^^^^ emojis could refer to the top-level value emojis or the .emojis property of the current element, so compiler must emit code for both cases
    | note: Migrate to modern syntax to avoid the ambiguity. This will become an error in the future.

    Outcome always:

    @omega I am using nginx as well. What do you suggest could be the Problem?

  • Community Rep

    @majr said in Cannot get emojis to work:


    Do you have nodebb-plugin-emoji installed?

  • Global Moderator Plugin & Theme Dev

    @omega can you look for 404 errors in your browser console? It sounds like the emoji images are pointing to the wrong place.

  • Global Moderator Plugin & Theme Dev

    @majr it looks like you aren't on the latest version of the plugins. Try this:

    npm install [email protected] [email protected]
    ./nodebb stop
    ./nodebb activate emoji
    ./nodebb activate emoji-android
    ./nodebb build
    ./nodebb start

    You should not see the require a peer of [email protected]^2.0.0 warning or the ambiguous inner begin warning. Regardless, these are warnings that you can usually ignore. They're meant for plugin devs, not for users. Also in the future, please share the whole error, not one randomly cut off.

    Then Build Emoji Assets from the plugin page, wait 30sec, and do this:

    ./nodebb stop
    ./nodebb build
    ./nodebb start
  • Community Rep


    Yea a ton of errors

    FetchEvent.respondWith received an error: TypeError: Not allowed to request resource

    Also web socket wss: connection failures too all resolving to the plugin folders and/or emojis folders/resrouces.

  • Global Moderator Plugin & Theme Dev

    @omega can you share more information? Like a screenshot of your console showing all of the errors?

    Or even give me a link to your site so I can investigate.

  • Community Rep

    @pitaj Solved!

    You think I would have configured this right... the refresh was the clue... I forgot to set the http to https in the config.json file... thanks for pointer to look in the browser console! It was easier to observe the flip from http to https when refreshing. 😲

  • @pitaj

    Hello, thank you for all your help but it made no difference. I did it exactly as you explained.

    I have one error in the console of the browser. Transplated in English
    the android plugin says:
    "Failed to load resource: The request timed out". That would be a little bit strange.

    I wonder why. Is my server too slow to show emojis? I am using nginx.

  • Global Moderator Plugin & Theme Dev

    @majr please provide the full error. Include what resource it says timed out.

    Do you have any errors in the server log?

    Is your site public? I'd like to see what's going on.

  • @pitaj
    This is the full error I see. There is no more text.
    But yes, it is public:
    -> Forum

    in the category "Neuigkeiten" I for now allowed to create and edit topics for guests so that you can try it without logging in.

    Thank you very much!

  • Global Moderator Plugin & Theme Dev

    @majr please check the url value in your config.json. It appears that you left the :4567 port at the end, while your site is not publicly at that port. The url value in config.json should be set to exactly the URL at which you access your site: https://forum.eltern-team-up.de

  • @pitaj
    oh my goodness - that was it! I feel very stupid now. Thank you very much!!!

  • Hello!
    Sorry to intrude, but I have an issue with emojis too.
    I can't get them to work since I tried adding new ones since my latest nodebb upgrade.

    I'm on nodebb v1.16.2
    node v14.16.0

    I've had them working in the past without any issue.
    Since I've updated to v1.16.2 everything was working fine then I tried adding some new emojis and from there the issue started.

    Once I added emojis as usual, I had this error Failed to load emoji metadata on the frontend and the backend.
    I tried the 'Build Emoji Asset' button and a new error Cannot read property forEach of undefined showed up.

    I had the latest nodebb-plugin-emoji plugin and the nodebb-plugin-emoji-android activated.

    I did a ./nodebb build and everything went fine but the issues were still there.

    I tried deactivating the plugins, deleting them and installing them again but the issue is still there.

    I deleted the nodebb-plugin-emoji-android and tried the nodebb-plugin-emoji-apple since the last one shows to be v1.16.2 compatible but nothing new happened here.

    When I run a ./nodebb log I get this:

    error: [emoji] Failed to retrieve data for parse ENOENT: no such file or directory, open '/var/www/nodebb/node_modules/nodebb-plugin-emoji/build/emoji/table.json' {"errno":-2,"code":"ENOENT","syscall":"open","path":"/var/www/nodebb/node_modules/nodebb-plugin-emoji/build/emoji/table.json","stack":"Error: ENOENT: no such file or directory, open '/var/www/nodebb/node_modules/nodebb-plugin-emoji/build/emoji/table.json'"}

    So it seems that I'm missing a table.json file but I have no clue where to find it.

  • Global Moderator Plugin & Theme Dev

    @taloche if Build Emoji Assets isn't working there's something weird going on. Do you have any custom emoji or extensions?

    The issues your described are all related. table.json is the emoji metadata, it's produced when you build emoji assets. So the failure to build is causing the other issues.

    What version of those plugins are you on?

  • @pitaj hi! Thanks for the reply on a Saturday.
    No custom emoji or plugin installed.
    nodebb-plugin-emoji : 3.5.0-0
    nodebb-plugin-emoji-apple : 2.0.5

    I only had personal emojis added through the nodebb-plugin-emoji plugin with the pencil button.

    Other plugins installed, all up-to-date


  • Global Moderator Plugin & Theme Dev

    @taloche what database are you on?

Suggested Topics

| |