• Hello, I'm facing this error when I attempt a ./nodebb setup according to this tutorial:

    I'm trying this on a fresh Digital Ocean Droplet. Could anyone, please, help me out?

    nodebb# sudo ./nodebb setup
    Dependencies outdated or not yet installed.
    Installing them now...
    
    npm ERR! code ERESOLVE
    npm ERR! ERESOLVE unable to resolve dependency tree
    npm ERR!
    npm ERR! While resolving: nodebb@1.16.2
    npm ERR! Found: nodebb-plugin-emoji@3.4.2
    npm ERR! node_modules/nodebb-plugin-emoji
    npm ERR!   nodebb-plugin-emoji@"^3.3.0" from the root project
    npm ERR!
    npm ERR! Could not resolve dependency:
    npm ERR! peer nodebb-plugin-emoji@"^2.0.0" from nodebb-plugin-emoji-android@2.0.0
    npm ERR! node_modules/nodebb-plugin-emoji-android
    npm ERR!   nodebb-plugin-emoji-android@"2.0.0" from the root project
    npm ERR!
    npm ERR! Fix the upstream dependency conflict, or retry
    npm ERR! this command with --force, or --legacy-peer-deps
    npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
    npm ERR!
    npm ERR! See /root/.npm/eresolve-report.txt for a full report.
    
    npm ERR! A complete log of this run can be found in:
    npm ERR!     /root/.npm/_logs/2021-02-02T23_03_52_241Z-debug.log
    Error installing dependencies!
    message: Command failed: npm install --production
    stdout: null
    stderr: null
    /root/nodebb/src/cli/package-install.js:81
                    throw e;
                    ^
    
    Error: Command failed: npm install --production
        at checkExecSyncError (child_process.js:616:11)
        at Object.execSync (child_process.js:652:15)
        at Object.installAll (/root/nodebb/src/cli/package-install.js:72:9)
        at Object.<anonymous> (/root/nodebb/src/cli/index.js:62:18)
        at Module._compile (internal/modules/cjs/loader.js:1063:30)
        at Object.Module._extensions..js (internal/modules/cjs/loader.js:1092:10)
        at Module.load (internal/modules/cjs/loader.js:928:32)
        at Function.Module._load (internal/modules/cjs/loader.js:769:14)
        at Module.require (internal/modules/cjs/loader.js:952:19)
        at require (internal/modules/cjs/helpers.js:88:18) {
      status: 1,
      signal: null,
      output: [ null, null, null ],
      pid: 15441,
      stdout: null,
      stderr: null
    }
    
    
  • Global Moderator Plugin & Theme Dev

    @alligator this is a thing that we need to fix, but for a temporary fix please use an older version of Node


  • me too

    9fcf516f-fe52-44b4-8542-d8c0cdcae526-image.png

  • Global Moderator Plugin & Theme Dev

    @ivorzk this will be fixed in 1.17.0

    I recommend you use Node 14 for now.


  • Global Moderator Plugin & Theme Dev

    @ivorzk ah sorry it's actually the npm version that matters here. You need to downgrade to the previous major version:

    npm install --global npm@6
    

  • @pitaj Thank you


  • I checked out v1.16.2 of the forum and was running node version 15.12 when I encountered the same error.
    I downgraded to node version 14.6.0 and now this error is not coming up.

    I hope this info can help anyone.

Suggested Topics

  • 12
  • 4
  • 8
  • 12
  • 2
| |