• Hi, guys
    I've stumbled upon the Mailgun plugin — the site doesn't seem to be sending any emails.
    I added a custom domain at Mailgun website (mg.c4d.space). All NDS records are checked and valid. After that at the domain page I found this info:

    I filled it here:

    When I send test emails nothing happens. I only get small popup windows in the bottom right corner of the page telling that email sent. But I see no activity in the nodebb logs (./nodebb log) and there is no activity in the Mailgun logs. Mailgun doesn't receive anything from the site.
    Please, tell me what I'm doing wrong here?

    Thanks in advance!

  • @aleksei
    Domain field in this plugin is NOT the full API url, but just the domain part - so your case mg.c4d.space.

    It isn't guaranteed to work even with that change though, since it's based on a mailgun-js package that wasn't maintained for 2 years now.

  • @oplik0 said in Can't make Mailgun work:

    since it's based on a mailgun-js package that wasn't maintained for 2 years now.

    @oplik0 , oh I see. Most probably this is the case. Because I tried to use different domains including mg.c4d.space, but nothing worked.

    Can you advise any other mailing plugin for the NOdeBB, which is the same easy to use as Mailgun?

  • @aleksei Well, you can actually still use mailgun - just not with their API, but SMTP directly.
    Uninstall the plugin and instead in /admin/settings/email check Use an external email server to send emails, select mailgun from the services dropdown below and input your SMTP credentials.

    You can get the credentials by following the instructions in this mailgun help post

    Other than that I think SendGrid, Mailchimp/Mandrill and AWS SES have maintained plugins for NodeBB (with SendGrid being the service used by NodeBB team). You can also get a lot more services to work with SMTP - I mainly use SparkPost with SMTP for example

  • @oplik0 the SMTP didn't work either. But thank you very much for pointing at the other services! I've just tried SendGrid and it worked perfectly from the 1st attempt.

Suggested Topics

| | | |