User Stuck in Registration Queue

Technical Support
  • Hello,

    A user has tried to join my private nodeBB forum. Normally we just hit the red x next to their request in the registration queue and they disappear. Tried that with this user, they disappear but when I reload the registration queue they are back again. I tried hitting the tick to accept them and then delete the user, but I get "Error Invalid Data", so I cannot accept them either. Restarted the forum but the user request is stuck like this. The events log shows the attempts to reject the user but not the attempts to approve the request. The other logs don't show much of anything. Couldn't find any other issues like this mentioned on the forums, does anyone have any ideas?



  • What are the contents of the registration queue in the database? Run the below in mongodb cli.

    db.objects.find({_key: "registration:queue"});

    If the username is there, then run this

    db.objects.find({_key: "registration:queue:name:<replace_with_username>"}); 

    Let me know what those queries return.

  • Hi Baris,

    Sorry for the delayed reply, I had a bit of trouble getting access to the terminal.

    I'm not super good with databases, but my tech guy tells me it's on redis rather than mongodb. You wouldn't happen to know how to do the same query in redis would you?


  • In redis it would be zrange registration:queue 0 -1 and then hgetall registration:queue:name:<replace_with_username>

  • Hi Baris,

    So there is now a second user stuck in the queue, but also we have since blocked or allowed several other users with no problems.

    This is what the query returned, appreciate your help so far!


  • Can you try

    hgetall "registration:queue:name:Kallie\r\n"
    hgetall "registration:queue:name:Hermina\r\n"
  • @Craig Hi Craig, issue is fixed in

    You can remove those entries with the below commands.

    zrem registration:queue Hermina\r\n
    zrem registration:queue Kallie\r\n
    del registration:queue:name:Hermina\r\n
    del registration:queue:name:Kallie\r\n

    Thanks for reporting.

  • Just a quick follow up on this because I finally got around to sorting it out and in case anyone else is running into the same issue. After a bit of stuffing around I realized there was an issue with the commands, they needed some extra quotation marks (as per @PitaJ 's suggestion):

    zrem registration:queue "Hermina\r\n"
    zrem registration:queue "Kallie\r\n"
    del "registration:queue:name:Hermina\r\n"
    del "registration:queue:name:Kallie\r\n"

    This got everything sorted. Appreciate everyone's help!!

Suggested Topics