• GNU/Linux

    hopefully centos 8 doesn't have this issues πŸ™‚ thanks @BAKA

  • GNU/Linux

    I've updated the gcc version but there is still the issue with RHEL/centos 7 @julian you should check nodebb compatibility with EL7. Else remove EL7 from the supported list.

  • GNU/Linux Admin

    @Sandeep where do we say we support CentOS? Just wondering, because we shouldn't, we try to be platform agnostic but target Ubuntu mainly.

  • GNU/Linux

    okay thanks, probably stop using nodebb then πŸ™‚

    remove the docs from here

  • GNU/Linux Admin

    @Sandeep yes, the CentOS guide here is community supported, it should still work regardless (though you'll likely need to install the build tools so sharp can compile).

  • GNU/Linux

    sharp compiles fine no issue @julian

    its on centos 7 :

    [root@server nodebb]# npm install sharp
    
    > husky@4.2.1 install /home/removed/web/removed.com/nodebb/node_modules/husky
    > node husky install
    
    husky > Setting up git hooks
    husky > Done
    
    > sharp@0.24.0 install /home/removed/web/removed.com/nodebb/node_modules/sharp
    > (node install/libvips && node install/dll-copy && prebuild-install) || (node-gyp rebuild && node install/dll-copy)
    
    info sharp Detected globally-installed libvips v8.9.1
    info sharp Building from source via node-gyp
    make: Entering directory `/home/removed/web/removed.com/nodebb/node_modules/sharp/build'
      TOUCH Release/obj.target/libvips-cpp.stamp
      CXX(target) Release/obj.target/sharp/src/common.o
      CXX(target) Release/obj.target/sharp/src/metadata.o
      CXX(target) Release/obj.target/sharp/src/stats.o
      CXX(target) Release/obj.target/sharp/src/operations.o
      CXX(target) Release/obj.target/sharp/src/pipeline.o
      CXX(target) Release/obj.target/sharp/src/sharp.o
      CXX(target) Release/obj.target/sharp/src/utilities.o
      SOLINK_MODULE(target) Release/obj.target/sharp.node
      COPY Release/sharp.node
    make: Leaving directory `/home/removed/web/removed.com/nodebb/node_modules/sharp/build'
    
    > husky@4.2.1 postinstall /home/removed/web/removed.com/nodebb/node_modules/husky
    > opencollective-postinstall || exit 0
    
    Thank you for using husky!
    If you rely on this package, please consider supporting our open collective:
    > https://opencollective.com/husky/donate
    
    npm WARN nodebb-plugin-emoji-android@2.0.0 requires a peer of nodebb-plugin-emoji@^2.0.0 but none is installed. You must install peer dependencies yourself.
    npm WARN textcomplete.contenteditable@0.1.1 requires a peer of textcomplete@^0.14.2 but none is installed. You must install peer dependencies yourself.
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.2 (node_modules/fsevents):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.2: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
    
    + sharp@0.24.0
    added 618 packages from 785 contributors, updated 1 package and audited 15834 packages in 44.557s
    
    33 packages are looking for funding
      run `npm fund` for details
    
    found 1 high severity vulnerability
      run `npm audit fix` to fix them, or `npm audit` for details
    
  • GNU/Linux

    @julian please let me know if you still think its sharp issue, since it is installed fine.

Suggested Topics

| |