• GNU/Linux

    hi there is a bug with logo upload getting 502 error and nodebb child exited

    [cluster] Child Process (11889) has exited (code: null, signal: SIGSEGV)
    [cluster] Spinning up another process...
    
  • GNU/Linux

    Bump.... Can some one look into it as this bugs are critical, can't personalize the logo.

  • Global Moderator

    That's not the full error, can you provide more context from the logs?

  • GNU/Linux

    @PitaJ ./nodebb log outputs only this error how can i debug more ?

    I use :

    Node.js v12.15.0
    Nodebb 1.13.2
    MongoDB 4.2.3
    
  • GNU/Linux

    i get this lines in log under dev mode ./nodebb dev

    2020-02-09T09:13:48.961Z [4567/13677] - info: NodeBB is now listening on: 0.0.0.0:4567
    2020-02-09T09:13:53.613Z [4567/13677] - verbose: [plugins/fireHook] static:sockets.validateSession
    2020-02-09T09:13:54.106Z [4567/13677] - verbose: [plugins/fireHook] static:sockets.validateSession
    2020-02-09T09:13:54.107Z [4567/13677] - verbose: [plugins/fireHook] filter:topics.unreadCutoff
    2020-02-09T09:13:54.118Z [4567/13677] - verbose: [plugins/fireHook] filter:user.getSettings
    2020-02-09T09:13:54.118Z [4567/13677] - verbose: [plugins/fireHook] filter:user.notificationTypes
    2020-02-09T09:13:54.123Z [4567/13677] - verbose: [plugins/fireHook] filter:topics.getUnreadTids
    2020-02-09T09:13:58.580Z [4567/13677] - verbose: [plugins/fireHook] static:sockets.validateSession
    2020-02-09T09:13:58.588Z [4567/13677] - verbose: [plugins/fireHook] filter:admin/settings/general.build
    2020-02-09T09:13:58.588Z [4567/13677] - verbose: [plugins/fireHook] filter:middleware.render
    2020-02-09T09:13:58.589Z [4567/13677] - verbose: [plugins/fireHook] filter:meta.getMetaTags
    2020-02-09T09:13:58.589Z [4567/13677] - verbose: [plugins/fireHook] filter:meta.getLinkTags
    2020-02-09T09:13:58.593Z [4567/13677] - verbose: [plugins/fireHook] filter:user.getSettings
    2020-02-09T09:13:58.593Z [4567/13677] - verbose: [plugins/fireHook] filter:user.notificationTypes
    2020-02-09T09:13:58.593Z [4567/13677] - verbose: [plugins/fireHook] filter:config.get
    2020-02-09T09:13:58.597Z [4567/13677] - verbose: [plugins/fireHook] filter:widget.render:html
    2020-02-09T09:14:06.093Z [4567/13677] - verbose: Saving file site-logo.png to : /home/nodebb/public/uploads/system/site-logo.png
    [cluster] Child Process (13677) has exited (code: null, signal: SIGSEGV)
    [cluster] Spinning up another process...
    
  • GNU/Linux

    Still waiting ... Bump

  • GNU/Linux Gamers

    Have you made sure the directory you are uploading to has the correct folder permissions?

    I'd also check to make sure the file doesn't already exist with some weird permissions that won't allow it to be overwritten.

  • GNU/Linux

    hi i use the U:G as root:root

    the logo is uploaded as i stated above nodebb is spinning the child process and I'm unable to save the logo from gui admin (as well as the touchicon having the same issue) favicon icon uploaded just fine and I'm able to use it. The Issue is logo upload and touchicon.
    [cluster] Child Process (13677) has exited (code: null, signal: SIGSEGV)
    [cluster] Spinning up another process...

    [root@board ~]# ls -la /home/nodebb/public/uploads/system
    total 36
    drwxr-xr-x 2 root root 4096 Feb  8 14:19 .
    drwxr-xr-x 8 root root 4096 Dec 20 08:50 ..
    -rw-r--r-- 1 root root    1 Dec 20 08:43 .gitignore
    -rw-r--r-- 1 root root 4286 Feb  8 14:10 favicon.ico
    -rw-r--r-- 1 root root 8044 Feb  9 03:14 site-logo.png
    -rw-r--r-- 1 root root 8044 Feb  8 14:19 touchicon-orig.png
    
  • GNU/Linux

    @julian can you please look into it ?

  • GNU/Linux Admin

    Don't run NodeBB as root. chown the entire directory as an unprivileged user and run NodeBB as that user.

  • GNU/Linux

    @julian yes done still the same issue, U/G is now a user

  • GNU/Linux Admin

    The segmentation fault isn't something related to NodeBB. Possibly one of our dependencies. I'd recommend deleting node_modules/ and running npm i --production again. Make sure you have build-essential meta package installed on your OS.

  • GNU/Linux

    @julian said in Can't upload logo:

    npm i --production

    experiencing the same issue after following the instructions.

    [cluster] Child Process (1546) has exited (code: null, signal: SIGSEGV)
    [cluster] Spinning up another process...
    
  • GNU/Linux Admin

    I'm sorry, I do not know how to resolve your issue, as it does not seem like a code problem with NodeBB, but a problem with your server or installation of Node.js, etc.

  • GNU/Linux

    @julian favicon is uploading just fine, why the issue are only with uploading logo and touchicon ?
    I didn't think its the issue with nodejs as its using official repo installation (centos 7)

  • GNU/Linux Admin

    Please try using Ubuntu 18.04


  • I met just same probelm too when I try to install nodebb last day. I can upload favicon but can't upload any other images. I used the same centos7 and v12.15.0 node.js. I looked up the installation log, it shows some modules did not installed well. For me it were sharp and some other modules. I guess it's the sharp module which is used to crop the images uploaded caused this problem. Sharp module need 'CXXABI_1.3.8' to compile and my default yum source did not have the gcc version needed. Maybe you can upgrade your gcc version and try reinstalling it by using "npm install sharp"? Hope this can help.

  • GNU/Linux Admin

    That is a good clue @BAKA, this is likely the issue. Perhaps sharp needs to be compiled manually by npm.

  • GNU/Linux

    @BAKA said in Can't upload logo:

    I met just same probelm too when I try to install nodebb last day. I can upload favicon but can't upload any other images. I used the same centos7 and v12.15.0 node.js. I looked up the installation log, it shows some modules did not installed well. For me it were sharp and some other modules. I guess it's the sharp module which is used to crop the images uploaded caused this problem. Sharp module need 'CXXABI_1.3.8' to compile and my default yum source did not have the gcc version needed. Maybe you can upgrade your gcc version and try reinstalling it by using "npm install sharp"? Hope this can help.

    thanks @BAKA for the info, i'll install ubuntu 18.04 and get back here.

  • GNU/Linux

    @julian thanks on ubuntu 18.04 there is no such issue. Centos 7 have issues which @BAKA mentioned with GCC version.

Suggested Topics

| |