[1.12.2] Default install and looking the log file



  • So, I watched the log file output.log from NodeBB directory and I noticed two things.

    1- The time in log file doesn't respect my system time :

    2019-10-18T05:52:57.076Z [4567/1114] - warn: [plugins/load] The following plugins may not be compatible with your version of NodeBB. This may cause unintended behaviour or crashing. In the event of an unresponsive NodeBB caused by this plugin, run `./nodebb reset -p PLUGINNAME` to disable it.
      * nodebb-plugin-composer-default
      * nodebb-theme-persona
      * nodebb-plugin-mentions
      * nodebb-rewards-essentials
    
    # date
    Fri Oct 18 07:54:00 CEST 2019
    

    2- The server always restart according to log file and sometimes I can see the spin icon on UI.
    It is certainly because of the warning precisely telling me that these modules are not yet compatible.
    However, I did the default installation without adding a plugin myself.


  • Global Moderator

    1. It's using UTC time, this avoids issues where you and the server are in different places, or you have multiple servers in different time zones.

    2. Please share the portion of your log file that you're referring to. I doubt it is because a module was incorrectly excluded from the default install but there is the possibility something messed up.


  • Gamers

    @Cassette-Chroot Did you use the master branch, or 1.12.x branch? Because while master will appear to be 1.12.2 in ACP (if I remember correctly), it's not really 1.12.2.
    It's actually a development branch and while everything should work (there is a reason for all these automated builds) at a basic level, there may be some bugs and some thing could be incompatible.



    1. @PitaJ thanks, in my use case forum are only for 1 timezone/country (france). If exist a way to use custom timezone let me know please but if not, it's not really a problem. ๐Ÿ‘

    2. @PitaJ and @oplik0 exactly I use the master. ๐Ÿ‘ผ
      The doc tell to use 1.11.x, is it the latest stable version ?
      Do I need always to use a branche and don't use tag ?
      What is the difference between 1.11.2 tag and 1.11.x branche ?
      (If I try to make a module or theme it's maybe better to start with 1.12.x branche ?)

    Thanks for your time.
    Regards.


  • Global Moderator

    @Cassette-Chroot please share the portion of the log file which contains the error that caused NodeBB to crash.

    v1.12.x is the latest stable release. We recommend you use the branch, and the docs for upgrading assume that. Whatever docs you're referring to are out of date.

    The v1.12.2 tag just refers to a single commit where that release was made. This is purely for convenience if you wish to select a specific patch version, not a specific minor version. The v1.12.x branch will get backported fixes, and makes upgrading much easier. This is why it's recommended.



  • @PitaJ here is the error in log file :

    2019-10-18T17:05:42.108Z [4567/21070] - info: Routes added
    2019-10-18T17:05:42.110Z [4567/21070] - info: NodeBB Ready
    2019-10-18T17:05:42.115Z [4567/21070] - info: Enabling 'trust proxy'
    2019-10-18T17:05:42.119Z [4567/21070] - info: NodeBB is now listening on: 0.0.0.0:4567
    2019-10-18T17:07:09.315Z [4567/21070] - info: [app] Shutdown (SIGTERM/SIGINT) Initialised.
    2019-10-18T17:07:09.318Z [4567/21070] - info: [app] Web server closed to connections.
    2019-10-18T17:07:09.318Z [4567/21070] - info: [app] Live analytics saved.
    2019-10-18T17:07:09.321Z [4567/21070] - info: [app] Shutdown (SIGTERM/SIGINT) Initialised.
    2019-10-18T17:07:09.322Z [4567/21070] - error: Server is not running.
    [cluster] Child Process (21070) has exited (code: 0, signal: null)
    
    NodeBB v1.12.2 Copyright (C) 2013-2014 NodeBB Inc.
    This program comes with ABSOLUTELY NO WARRANTY.
    This is free software, and you are welcome to redistribute it under certain conditions.
    For the full license, please visit: http://www.gnu.org/copyleft/gpl.html
    
    Clustering enabled: Spinning up 1 process(es).
    
    2019-10-18T17:07:10.439Z [4567/21113] - info: Initializing NodeBB v1.12.2 https://domain.name
    2019-10-18T17:07:12.299Z [4567/21113] - info: [socket.io] Restricting access to origin: https://domain.name:*
    
    2019-10-18T17:07:12.561Z [4567/21113] - warn: [plugins/load] The following plugins may not be compatible with your version of NodeBB. This may cause unintended behaviour or crashing. In the event of an unresponsive NodeBB caused by this plugin, run `./nodebb reset -p PLUGINNAME` to disable it.
      * nodebb-plugin-composer-default
      * nodebb-theme-persona
      * nodebb-plugin-mentions
      * nodebb-rewards-essentials
    

    each 3 minutes average it restart and add new lines to log file.

    Thanks for this explanation ๐Ÿ™ I will use 1.12.x
    The doc used is https://docs.nodebb.org


  • Global Moderator

    @Cassette-Chroot odd, doesn't seem to have printed the error. Can you try running it without systemd, using ./nodebb slog and see if it catches any errors?



  • @PitaJ I let running this night and write back to you.
    Thanks



  • If the nodebb app is just exiting with no errors check if your system has enough ram and swap.



  • @PitaJ @baris good morning,
    Because of misconfigured systemd file and exactly the PIDFile path.
    My bad.
    However, I am impressed by your response time. It's amazing.
    Thanks again.
    About timezone there is a way to change the default ?
    Look, my server is located in Netherland but the server timezone is Paris. it's more comfortable for me.



  • https://github.com/NodeBB/NodeBB/blob/master/src/prestart.js#L26 need to change toISOString on that line.



  • @baris
    ok and I can use the conf file to use like a +2 string and make a PR ?


Log in to reply
 

Suggested Topics

| |