when I installed `nodebb-plugin-poll`,Log display warning information.



  • 2019-03-09T03:14:55.233Z [4567/26838] - ?[33mwarn?[39m: [deprecated] requiring core modules with `module.parent.require('./database')` is deprecated. Please use `require.main.require("./src/<module_name>")` instead. 
        at /root/nodebb/node_modules/nodebb- plugin-poll/lib/nodebb.js:5:14 
    2019-03-09T03:14:55.234Z [4567/26838] - ?[33mwarn?[39m: [deprecated] requiring core modules with `module.parent.require( './settings')` is deprecated. Please use `require.main.require("./src/<module_name>")` instead.
        at /root/nodebb/node_modules/nodebb-plugin-poll/lib/nodebb.js:6:20
    2019-03-09T03:14:55.234Z [4567/26838] - ?[33mwarn?[39m: [deprecated] requiring core modules with `module.parent.require('./meta')` is deprecated. Please use ` require.main.require("./src/<module_name>")` instead. 
        at /root/nodebb/node_modules/nodebb-plugin-poll/lib/nodebb.js:7:16 
    2019-03-09T03:14: 55.235Z [4567/26838] - ?[33mwarn?[39m: [deprecated] requiring core modules with `module.parent.require('./user')` is deprecated. Please use `require.main.require(". /src/<module_name>")` instead. 
        at /root/nodebb/node_modules/nodebb-plugin-poll/lib/nodebb.js:8:16 
    2019-03-09T03:14:55.235Z [4567/26838] - ?[33mwarn?[39m: [deprecated] requiring core modules with `module.parent.require('./posts')` is deprecated. Please use `require.main.require("./src/<module_name>")` instead.
        at /root/nodebb/node_modules/nodebb-plugin-poll/lib/nodebb.js:9:17 
    2019-03-09T03:14:55.236Z [4567/26838] - ?[33mwarn?[39m: [deprecated] requiring core modules with `module.parent.require('./topics')` is deprecated. Please use `require.main.require("./src/<module_name>")` instead. 
        at /root/nodebb/node_modules/ nodebb-plugin-poll/lib/nodebb.js:10:18 
    2019-03-09T03:14:55.236Z [4567/26838] - ?[33mwarn?[39m: [deprecated] requiring core modules with `module.parent. require('./privileges')` is deprecated. Please use `require.main.require("./src/<module_name>")` instead. 
        at /root/nodebb/node_modules/nodebb-plugin-poll/lib/ nodebb.js:11:22
    2019-03-09T03:14:55.236Z [4567/26838] - ?[33mwarn?[39m: [deprecated] requiring core modules with `module.parent.require('./socket.io/plugins')` is deprecated . Please use `require.main.require("./src/<module_name>")` instead. 
        at /root/nodebb/node_modules/nodebb-plugin-poll/lib/nodebb.js:12:25 
    2019-03- 09T03:14:55.237Z [4567/26838] - ?[33mwarn?[39m: [deprecated] requiring core modules with `module.parent.require('./socket.io/admin')` is deprecated. Please use ` require.main.require("./src/<module_name>")` instead.  
        at /root/nodebb/node_modules/nodebb-plugin-poll/lib/nodebb.js:13:24
    2019-03-09T03:14:55.237Z [4567/26838] - ?[33mwarn?[39m: [deprecated] requiring core modules with ` module.parent.require('./socket.io/index')` is deprecated. Please use `require.main.require("./src/<module_name>")` instead.
        at /root/nodebb/node_modules/nodebb-plugin-poll/lib/nodebb.js:14:23 
    2019-03-09T03:14:55.238Z [4567/26838] - ?[33mwarn?[39m: [deprecated] requiring core modules with `module.parent.require('../public/src/modules/translator')` is deprecated. Please use `require.main.require("./src/<module_name>")` instead. 
        at /root/nodebb/node_modules/nodebb-plugin-poll/lib/nodebb.js:15:22 
    

  • GNU/Linux

    This happen because it need some maintenance. module.parent.require is outdated and needs to be replaced with require.main.require.
    Just ignore that, the plugin is working perfectly anyway. I believe that the creator of the plugin will update that briefly.



  • @jtsimoes You are really nice!


Log in to reply
 

Suggested Topics

  • 2
  • 8
  • 1
  • 8
  • 2
| |