Forced to refresh page after login because page doesn't load on login

Technical Support
  • Hi i have setup nodebb and was running fine but on last build i get the error below, can anyone help?
    after login is completed page doesn't load and unless i refresh the page i can't see i'm logged in

    Mongo v4.0.5
    Node v10.15.0
    npm 6.4.1
    nginx version: nginx/1.10.3 (Ubuntu)

    2019-01-29T13:01:01.526Z [4567/22491] - info: [build]         plugin static dirs                               build completed in 0.804sec
    2019-01-29T13:01:04.596Z [4567/22491] - warn: [meta/templates] Partial not loade                             d: partials/account/header.tpl
    2019-01-29T13:01:04.598Z [4567/22491] - warn: [meta/templates] Partial not loade                             d: partials/chats/user.tpl
    2019-01-29T13:01:04.598Z [4567/22491] - warn: [meta/templates] Partial not loade                             d: partials/chats/user.tpl
    io: 1 on [ { type: 2, nsp: '/', id: 28, data: [ 'admin.rooms.getAll' ] } ]
    2019-01-29T13:01:09.575Z [4567/22491] - warn: [meta/templates] Partial not loade                             d: partials/chats/user.tpl
    2019-01-29T13:01:09.576Z [4567/22491] - warn: [meta/templates] Partial not loade                             d: partials/chats/user.tpl
    io: 1 emit [ 'disconnecting', 'ping timeout' ]
    io: 1 emit [ 'disconnect', 'ping timeout' ]
    io: 1 emit [ 'disconnecting', 'ping timeout' ]
    io: 1 emit [ 'disconnect', 'ping timeout' ]
  • Have you tried running ./nodebb build and restarting? If there are any errors in the build command share them here.

  • @PitaJ that seem to have fixed the issue.

    However now i get this just by simply clicking restart

    2019-01-30T00:06:23.202Z [4567/30189] - warn: [deprecated] requiring core modules with `module.parent.require('./meta')` is deprecated. Please use `require.main.require("./src/<module_name>")` instead.
        at /home/nodebb/node_modules/nodebb-theme-lavender/lib/theme.js:5:24
  • @minerric You can ignore that error it is fixed in the latest version of Lavender.

  • @baris thank you for the update should i then reinstall the theme and rebuild?

  • Hello,

    I have the same issue, when I try to login I am getting not redirected, after I refresh the page I am logged in. I can't see any error in the log files but this error appears in the chrome console

    Uncaught (in promise) TypeError: Cannot read property 'slice' of undefined
        at (app.js:781)
        at app.js:152
    app.reskin	@	app.js:781
    (anonymous)	@	app.js:152
    Promise.then (async)		
    (anonymous)	@	app.js:145
    execCb	@	require.js:29
    check	@	require.js:18
    enable	@	require.js:23
    init	@	require.js:16
    (anonymous)	@	require.js:26
    setTimeout (async)		
    g.nextTick	@	require.js:32
    c	@	require.js:26
    requirejs	@	require.js:32
    app.updateHeader	@	app.js:115
    success	@	login.js:42
    t.success	@	jquery.form.min.js:7
    c	@	jquery.js:3268
    fireWith	@	jquery.js:3398
    $	@	jquery.js:9305
    (anonymous)	@	jquery.js:9548
    load (async)		
    send	@	jquery.js:9567
    ajax	@	jquery.js:9206
    e.fn.ajaxSubmit	@	jquery.form.min.js:7
    (anonymous)	@	login.js:34
    dispatch	@	jquery.js:5183
    m.handle	@	jquery.js:4991

    If it is related to a theme I am using the Material Design Theme

  • @Ne-Ho Try with persona does it happen there?

  • This should be fixed on latest master, thanks for reporting.

  • @baris I forgot to answer your question, with persona everything works fine

Suggested Topics

  • 1 Votes
    1 Posts
  • 0 Votes
    18 Posts
  • Redis on Amazon's Elastic cache

    Solved Technical Support
    0 Votes
    2 Posts
  • 0 Votes
    4 Posts
  • 0 Votes
    6 Posts