[solved] Error running `./nodebb upgrade` when updating from v1.10.1 to v1.10.2

Technical Support
  • First of all, here's the console output and here's the contents of the full log

    I'm upgrading from NodeBB 1.10.1 to 1.10.2 following the upgrade guide, and run into an error whenever I run ./nodebb upgrade. I followed the steps in the guide without issue (shutdown, backup git fetch/reset), but ./nodebb upgrade errors out no matter what I do. It appears to be an issue with [email protected] not finding the file node_modules/sharp/install/libvips, which I can confirm is not on the disk.

    I'm not sure how to fix this issue, any advice would be appreciated.

    System info:

    • Ubuntu Server 18.04 LTS 4.15.0-39-generic
    • node -v: v10.13.0
    • npm -v: 6.4.1

    EDIT: I attempted to solve the issue by running rm -rf node_modules; ./nodebb upgrade and am now getting the following error:

    > [email protected] install /var/www/friendos.club/node_modules/benchpressjs
    > cd rust/benchpress-rs && npm install
    sh: 1: cd: can't cd to rust/benchpress-rs
    npm ERR! code ELIFECYCLE
    npm ERR! errno 2
    npm ERR! [email protected] install: `cd rust/benchpress-rs && npm install`
    npm ERR! Exit status 2
  • I fixed my own issue. Apparently some install scripts fail when run as root (or with sudo). I'm not sure why this is the case, but I got everything to work by running sudo chown -R ralph:www-data /path/to/nodebb && ./nodebb upgrade as a standard user.

Suggested Topics