On which folder should I install plug ins ?

General Discussion

Suggested Topics


  • -1 Votes
    8 Posts
    2k Views

    @ALiveVam a community forum can be a bit daunting as it is an active, living entity, unlike a regular website. There are companies that do consulting on NodeBB and can build and maintain sites for you so that you don't have to do it on your own, as well.

  • 0 Votes
    1 Posts
    422 Views

    I want to have a task plug-in, when the user completes some of the action.
    i donβ€˜t know how to find it
    thank you !

  • 0 Votes
    3 Posts
    1k Views

    That worked. Thank you.

  • 0 Votes
    9 Posts
    10k Views

    @julian your explanation eases my concerns. Would be nice to see none at all but at least we know it's not critical to the operation of nodebb for production. Thank you!!

  • 0 Votes
    6 Posts
    3k Views

    I know this is old but it came up when I was looking for an answer, so for those that come after.....

    Redis is already on c9 and its old.
    Following is some quick instructions that get it working but please understand i REALLY DONT know what Im doing πŸ˜‰
    The instructions are base off...
    https://www.digitalocean.com/community/tutorials/how-to-install-and-use-redis

    Remove the old redis stuff
    Do you need to do this?...no idea πŸ˜‰

    $ sudo service redis-server stop $ sudo dpkg -P redis-server $ sudo dpkg -P redis-tools

    Download and make the new Redis 3.0.x

    paez@nodebb:~/workspace $ mkdir redis $ cd redis wget http://download.redis.io/releases/redis-stable.tar.gz tar xzf redis-stable.tar.gz cd redis-stable make sudo make install

    Install
    During the install the default path for where to put the executable s was wrong and I think it was /usr/bin/
    Also, select port 16379, because the old redis is still running and Im still not sure how to turn it off properly. But your new one will work fine if you set nodeBB to the new one. I did get rid of it once, but not exactly sure how.

    cd utils sudo ./install_server.sh

    And now you should have a working redis on 0.0.0.0:16379.
    Still have the old one running, as I dont know how to get rid of it properly yet.

    I tested this with the latest NodeBB and was able to get it to work except I get this error in the console....

    WebSocket connection to 'ws://nodebb-c9-paez.c9.io/socket.io/?EIO=3&transport=websocket&sid=Gn4rDgj2XlEILV0FAAAA' failed: Error during WebSocket handshake: Unexpected response code: 400

    ...and a whole bunch of....
    [deprecated] variables.set is deprecated, please use ajaxify.data...
    ...dont know why and am not likely to find out as Im going to be running it off Openshift, but this hopefully gets someone a little closer....and it does seem to work good enough for theme mucking which is what I wanted the c9 one for.