• @smartpunter What is your NodeBB version?

    See this.


    If u have problem with oxide style, report this in github .


  • Also got this error, anyone know why?

  • Global Moderator Plugin & Theme Dev

    @smartpunter downgrade to Node 10, and try again.


  • Yes, it works when using Node 10 LTS.


  • I finally managed to install your theme, looks great, but there is a bug...
    867d04b3-eeeb-478b-b864-23d747d45ea2-изображение.png

    On "/recent" and "/popular" (maybe some others) templates there is a big "authorise to post reply" button, even though i am already authorized. I tried to relogin, it didn't help.


  • @jinfagang Also I can not reinstall it, cause I have many my own config on the website. what should i do? Now I can not even start my nodebb server


  • @smartpunter How did you solve that, I installed node 10.15, the issue still exists.

    ➜  nodebb git:(master) ✗ ./nodebb log  
    
    Hit Ctrl-C to exit
    
    
    2019-02-19T13:26:22.992Z [4567/24589] - info: [build]                     sounds  build completed in 0.504sec
    2019-02-19T13:26:23.592Z [4567/24589] - info: [build]         plugin static dirs  build completed in 1.106sec
    2019-02-19T13:26:32.323Z [4567/24589] - info: [build]         client side styles  build completed in 9.835sec
    2019-02-19T13:26:34.028Z [4567/24589] - error: [build]                  templates  build failed
    2019-02-19T13:26:34.028Z [4567/24589] - error: [build] Encountered error during build stepProperty consequent of ConditionalExpression expected node to be of a type ["Expression"] but instead got null {"stack":"TypeError: Property consequent of ConditionalExpression expected node to be of a type [\"Expression\"] but instead got null\n    at Object.validate (/root/nodebb/node_modules/babel-types/lib/definitions/index.js:109:13)\n    at validate (/root/nodebb/node_modules/babel-types/lib/index.js:505:9)\n    at Object.builder (/root/nodebb/node_modules/babel-types/lib/index.js:466:7)\n    at Object.OpenIf (/root/nodebb/node_modules/benchpressjs/build/lib/compiler/compiler.js:115:14)\n    at compile (/root/nodebb/node_modules/benchpressjs/build/lib/compiler/compiler.js:160:49)\n    at Object.OpenIter (/root/nodebb/node_modules/benchpressjs/build/lib/compiler/compiler.js:127:246)\n    at compile (/root/nodebb/node_modules/benchpressjs/build/lib/compiler/compiler.js:160:49)\n    at compiler (/root/nodebb/node_modules/benchpressjs/build/lib/compiler/compiler.js:175:20)\n    at compileFallback (/root/nodebb/node_modules/benchpressjs/build/lib/precompile.js:37:17)\n    at Promise.try (/root/nodebb/node_modules/benchpressjs/build/lib/precompile.js:103:88)"}
    2019-02-19T13:26:37.127Z [4567/24589] - info: [build] admin control panel styles  build completed in 14.638sec
    2019-02-19T13:26:42.826Z [4567/24589] - info: [build]            admin js bundle  build completed in 20.338sec
    2019-02-19T13:26:49.470Z [4567/24589] - info: [build]           client js bundle  build completed in 26.983sec
    2019-02-19T13:26:52.337Z [4567/24589] - info: [build]                  languages  build completed in 29.849sec
    2019-02-19T13:26:57.219Z [4567/24589] - info: [build]          requirejs modules  build completed in 34.733sec
    ^C
    ➜  nodebb git:(master) ✗ node -v
    v10.15.1
    
    

    I have cleaned my build and reinstalled all packages


  • @smartpunter What version of the theme do you use?

    I do not have this problem.

    Zrzut ekranu z 2019-02-19 19-13-07.png Zrzut ekranu z 2019-02-19 19-13-15.png


    @jinfagang Install nodebb on a user other than root.


  • @youhosi Hi, I am able to using this wonder theme now. But the recent cards plugin I have installed but can not shown on main page, What did I miss?


  • @jinfagang You must set the theme in the widgets.


  • @youhosi said in [nodebb-theme-oxide] Oxide Style! 3.0.26:

    I do not have this problem.

    Unfortunately i do have 😞 Version is shown like this in ACP:

    nodebb-theme-oxide
    Installed 4.0.5 | Latest 4.0.5


  • Update to 4.0.8, install last version

    npm install nodebb-theme-oxide@latest

    Changelog: Commits

    • Improvement search and add better quicksearch,
    • Add small fixes

    Zrzut ekranu z 2019-02-21 23-57-27.png Zrzut ekranu z 2019-02-21 23-57-37.png


  • @youhosi said in [nodebb-theme-oxide] Oxide Style! 3.0.26:

    I do not have this problem.

    i have compared this part of code... This one from persona recent.tpl

    <!-- IF loggedIn -->
    <button component="category/post" id="new_topic" class="btn btn-primary">[[category:new_topic_button]]</button>
    <!-- ELSE -->
    <a component="category/post/guest" href="{config.relative_path}/login" class="btn btn-primary">[[category:guest-login-post]]</a>
    <!-- ENDIF loggedIn -->
    

    This one from oxide

    <!-- IF canPost -->
    <button component="category/post" id="new_topic" class="btn btn-primary">[[category:new_topic_button]]</button>
    <!-- ELSE -->
    <a component="category/post/guest" href="{config.relative_path}/login" class="btn btn-primary">[[category:guest-login-post]]</a>
    <!-- ENDIF canPost -->
    

    Maybe you should use loggedIn condition instead of canPost? Or it might be a bug in 'canPost' variable calculations... I would go with safer one, because you are showing 'guest-login-post' button and it doesn't connected with ability to post messages. So probably you should use "loggedIn" variable in all parts of code like this (recent.tpl and popular.tpl).



  • @youhosi : not able load more posts, pagination issue in mobile.


  • @techy-mast Create issuse in git repo


  • Is there a dark skin for this theme?


  • @djensen47 No, but you can adjust it yourself in the file less/bootstrap/vairables.less. The style in 90% support with the bootstrap.


  • Looks great!👍


  • Update to 4.0.14, install last version

    npm install nodebb-theme-oxide@latest

    Changelog: Commits

    • Fix theme build error,
    • Improvement section view in categories,
    • Clean code,
    • And more 😄

    Zrzut ekranu 2019-03-11 o 22.30.05.png

Suggested Topics

| |