• I forgot that I need to be on 1.7 to use the import plugin and set up a new 1.8 installation and spent a bunch of time putting things back the way they were.

    Last attempt to downgrade resulted in breaking of the admin screen.

    Is this a supported use case? I'm guessing that the better approach is to not try to in-place downgrade but have a separate installation, but would it work with our existing nodebb DB?

  • Global Moderator

    You can use the import plugin on 1.8 I think.

  • GNU/Linux Admin

    Hi @RogerLevy -- the import process should be fine, there aren't any major breaking changes.

    In fact, if you really want, our upgrade scripts are supposed to be idempotent, so you can run them again (by deleting the schemaLog value from the database) so that ./nodebb upgrade runs them all again.

    Alternatively, delete individual items from that sorted set.

    Alternatively, run individual upgrades by executing ./nodebb upgrade upgrade_script_name 😄

    Lots of options!

Suggested Topics

| |