[Solved]NodeBB and MongoDB not playing nice on CentOS

General Discussion
  • So I installed NodeBB from the wiki tutorials for installing and setting up with Mongo and CentOS, (the default user access deets in config.json are wrong for mongo) but when I start it up I get a blank interface. None of the extra stuff is setup.

    I also can't access the admin section even though I am the first and only user.


    The only stuff I've changed is setup MongoDB running on a different port for security. And I setup those in the initial setup.

    Also it still complains that it can not find convert - Did you install imagemagick?

    [ezra@Kiwidev community]$ which convert

    ^ yes I do have it installed.

    If I run ./nodebb upgrade I get:

    info: NodeBB v0.4.0 Copyright (C) 2013 DesignCreatePlay Inc.
    info: This program comes with ABSOLUTELY NO WARRANTY.
    info: This is free software, and you are welcome to redistribute it under certain conditions.
    warn: Couldn't find convert. Did you install imagemagick?
    warn: You have no mongo password setup!
    info: Beginning database schema update
    info: [2014/2/19] Updating MOTD to use the HTML widget - skipped
    info: [2014/2/20] Adding Recent Replies, Active Users, and Moderator widgets to category sidebar - skipped
    info: [2014/2/20] Adding Forum Stats Widget to the Homepage Footer - skipped
    info: [2014/2/20] Updating Lavender MOTD - skipped
    info: [2014/2/20] Activating NodeBB Essential Widgets - skipped
    info: [2014/2/22] Added categories to sorted set - skipped
    info: [2014/3/18] Migrating Markdown settings to new configuration - skipped
    info: [2014/3/21] Removing gids and pruning groups - skipped
    info: [2014/3/31] Re-adding copyright message into global footer widget - skipped
    info: [2014/4/1] Moved deprecated vanilla footer widgets into draft zone - skipped
    info: [upgrade] Schema already up to date!

    I'm presuming its skipping setting up all that stuff because it believe it already exists. And my Mongo password IS set, the fact I can register as a user proves it (i think).

  • I think I found the problem, will make a pull request on GIthub.

  • Or not..

    It looks like the variables built to access MongoDB's username and password should be user and pwd, not username and password.

    But those are referenced elsewhere in the setup files. I'll have a go, but Im not exactly sure which values to edit. xD

  • @Ezra-Sharp unless you've already done so, it may be worth while opening an issue on github for this: https://github.com/designcreateplay/nodebb/issues

  • Opps, I had, but it turned out I was selecting the wrong database. 😛

Suggested Topics