Kubernetes deployment

Solved Technical Support

Suggested Topics

  • 0 Votes
    6 Posts

    @julian Yeah, I totally should have expected this, after bundling up so many times several Vue projects these years, during which my CPU fan always screams and screeches.

  • 0 Votes
    1 Posts

    So.... I followed the instructions using this:
    and everything seemed to go smoothly, I started the app using Heroku, and the first page I get is:
    instead of the usual homepage, and it keeps telling me this message:
    238f50e5-e4b5-440e-a06e-07157b39dc58-image.png .

    I tried reading through others who had similar issues but failed to find what is wrong with my setup, and not really sure where to start looking as i am new to this. I'd appreciate any help i can get 🙂 thanks for your time

  • 0 Votes
    2 Posts

    @signal15 documentDB is not compatible with NodeBB. It is supposed to be a drop in replacement for MongoDB but the clients that we have that tried using it ran into some issues 😐

    Otherwise if you run into issues with FarGate, do post here and we'll work through them 😁

  • 0 Votes
    1 Posts

    Hey Guys!

    Which deployment tool is recommended for continuous deployment of nodebb from a development environment (using github) to our production server (CentOS 7 + nginx + Postgresql)?
    We've tried using PM2, but have encountered problems which NodeBB's compatibility with it @kfirba .


  • 1 Votes
    1 Posts


    I have followed the Heroku guide from the docs with no luck. Everything goes fine until I try to connect to the site when Heroku shows Application error page.

    Here's Heroku's app log:

    2017-03-29T21:22:03.000000+00:00 app[api]: Build succeeded 2017-03-29T21:22:23.566319+00:00 heroku[web.1]: Starting process with command `node loader.js --no-daemon` 2017-03-29T21:22:27.616058+00:00 heroku[web.1]: State changed from starting to crashed 2017-03-29T21:22:27.617327+00:00 heroku[web.1]: State changed from crashed to starting 2017-03-29T21:22:27.607752+00:00 heroku[web.1]: Process exited with status 0 2017-03-29T21:22:31.398032+00:00 heroku[web.1]: Starting process with command `node loader.js --no-daemon` 2017-03-29T21:22:36.001530+00:00 heroku[web.1]: Process exited with status 0 2017-03-29T21:22:36.003776+00:00 heroku[web.1]: State changed from starting to crashed

    I'm willing to provide you any information needed.