[nodebb-rewards-essentials] after upgrade: ErrorIllegal reward - no inputs found!

Unsolved General Discussion
  • After upgrading to v1.6.0 I get the following message displayed, when accessing the rewards admin page.

    Error Illegal reward - no inputs found! 

    The pull down menues for the then selection are empty.

    Here is a dump of the html code for one reward:

    #code block
    <form class="main inline-block">
    <div class="well inline-block">
    <label for="condition">If User's</label><br />
    <select name="condition" data-selected="essentials/user.postcount"> <option value="essentials/user.reputation">Reputation</option>
    <option value="essentials/user.postcount">Post Count</option>
    <option value="essentials/user.lastonline">Last Logged in Time</option>
    <option value="qanda/question.accepted">Times questions accepted</option>
    <div class="well inline-block">
    <label for="condition">Is:</label><br />
    <select name="conditional" data-selected="greaterorequalthan">
    <option value="greaterthan">></option>
    <option value="greaterorequalthan">>=</option>
    <option value="lesserthan"><</option>
    <option value="lesserorequalthan"><=</option>
    <option value="string">string:</option>
    <input type="text" name="value" value="1" />
    <div class="well inline-block">
    <label for="condition">Then:</label><br />
    <select name="rid" data-selected="essentials/add-to-group">
    <option value=""></option>

    As you can see the option field generating the pull down is empty

    I use the same rewards-essentials code I used on v1.4.x
    Any ideas?

  • In the mean time I upgraded to V1.6.1, but still the same problem.

    is @psychobunny still active?

    It seems he/she maintained the module

  • Open an issue on the github page for that plugin

  • @pitaj

    did that already.

    looking at the issue list and checking the modification dates of the code, it seems, that the module hasn't been maintained for a while.

    As the module is a default module for Nodebb I hope, that someone picks up the problems and starts maintaining the module again.

    Unfortunatelly my knowledge of Nodebb is not good enough to fix any problems 😞

  • What I tried in the mean time:

    did a fresh install of nodebb on my test system with

    git clone [email protected]:NodeBB/NodeBB.git -b v1.6.x

    run through the setup procedure , but kept the redis database.

    The problem remained.

    Then I

    • stopped nodebb
    • stopped redis
    • deleted the redis database files
    • started redis
    • run nodebb setup

    That way I got a clean install without data and with default settings.

    The problem still exists:

    When you define a new reward the forms and pull downs are populated.
    After saving the rewards, leaving the page and coming back, the pull down menus for existing rewards are not populated and empty, while creating a new reward works well.
    After saving and reloading the rewards page, the error 'illegal reward. no inuts found' is displayed.

    Last but not least, no rewards are awarded to users.

Suggested Topics