Login Unsuccessful Invalid login credentials error..



  • After a fresh installation I ran into a variety of problems so I decided to install once more and managed to make it to myip:4567 and got excited to find out that I can not log into my administrator account.

    ./nodebb log

    7/9 07:04:15 [5581] - info: [plugins] Plugins OK
    7/9 07:04:15 [5581] - verbose: [hotswap] Router with id plugins replaced successfully
    7/9 07:04:15 [5581] - verbose: [plugins] All plugins reloaded and rerouted
    7/9 07:04:15 [5581] - verbose: [hotswap] Router with id auth replaced successfully
    7/9 07:04:15 [5581] - info: Routes added
    7/9 07:04:15 [5581] - verbose: [meta/blacklist] Loading 0 blacklist rules
    7/9 07:04:15 [5581] - info: NodeBB Ready
    7/9 07:04:15 [5581] - info: Enabling 'trust proxy'
    7/9 07:04:15 [5581] - error: Error: listen EADDRINUSE 0.0.0.0:4567
    at Object.exports._errnoException (util.js:1020:11)
    at exports._exceptionWithHostPort (util.js:1043:20)
    at Server._listen2 (net.js:1258:14)
    at listen (net.js:1294:10)
    at net.js:1404:9
    at _combinedTickCallback (internal/process/next_tick.js:83:11)
    at process._tickCallback (internal/process/next_tick.js:104:9)
    7/9 07:04:15 [5581] - error: NodeBB address in use, exiting...
    3 restarts in 10 seconds, most likely an error on startup. Halting.

    I ran $ ps -ewwo pid,args | grep nodebb

    5509 node ./nodebb log
    5622 /root/.nvm/versions/node/v6.11.3/bin/node /root/nodebb/loader.js
    5632 /root/.nvm/versions/node/v6.11.3/bin/node /root/nodebb/app.js
    5646 grep --color=auto nodebb.

    ./nodebb log shows

    7/9 06:57:13 [5494] - info: Routes added
    7/9 06:57:13 [5494] - info: NodeBB Ready
    7/9 06:57:13 [5494] - info: Enabling 'trust proxy'
    7/9 06:57:13 [5494] - info: NodeBB is now listening on: 0.0.0.0:4567
    7/9 06:57:29 [5494] - error: /login
    invalid csrf token
    7/9 06:57:46 [5494] - error: /login
    invalid csrf token

    Any info or help would be greatly greatly appreciated!! Thank you


  • Global Moderator

    What OS are you on? Is the url property in config.json equal to the actual URL at which you are attempting to access your site?

    Did you follow any guides for installation? If so, which ones?



  • @pitaj yes I set it as my webhostIP:6379

    "url": "https://mykoreansurgery.com:6379",
    "secret": "",
    "database": "mongo",
    "port": 6379,
    "mongo": {
        "host": "127.0.0.1",
        "port": 27017,
        "username": "mksadmin-01",
        "password": "B...",
        "database": "nodebb"
    

    Im working on OS Sierra but using Digital Ocean for webhost so using Ubuntu 16.04 to access webhost.

    I followed the guide from http://www.debugrun.com/a/j28nSeK.html
    but decided to follow the offical mongodb site to download the newest version and follow their instructions



  • @pitaj Im trying to check mongodb if the website user/password was set or does it matter if I do that because my config.json file clearly states my username and password for the website?



  • @pitaj ~/nodebb# ./nodebb log

    Hit Ctrl-C to exit

    [deprecated] String.prototype.rtrim is deprecated as of NodeBB v1.5; use utils.rtrim instead.
    8/9 03:30:18 [8774] - info: [socket.io] Restricting access to origin: https://mykoreansurgery.com😘

    8/9 03:30:19 [8774] - warn: [plugins/load] The following plugins may not be compatible with your version of NodeBB. This may cause unintended behaviour or crashing. In the event of an unresponsive NodeBB caused by this plugin, run ./nodebb reset -p PLUGINNAME to disable it.

    • nodebb-plugin-markdown

    8/9 03:30:19 [8774] - info: Routes added
    8/9 03:30:19 [8774] - info: NodeBB Ready
    8/9 03:30:19 [8774] - info: Enabling 'trust proxy'
    8/9 03:30:19 [8774] - info: NodeBB is now listening on: 0.0.0.0:6379

    thought it was a problem with the port so i changed it to 6379 in config.json but it was originally default 4567



  • @mks5809 Are you using that port when you connect to the site? The URL value has to equal the actual URL being used. So the user would need to enter https://mykoreansurgery.com:6379 to get to your page and login successfully.



  • yes! I am using exactly what was written in config.json
    https://mykoreansurgery.com:6379

    Only problem is trying to login to my administrator account..It keeps prompting "Login Unsuccessful Invalid login credentials error" with the login/password I stated in the config.json file.


  • Global Moderator

    You don't specify the admin username and password in the config.json file. The ones in the config.json file are only for the database access. The ones for admin user were specified separately when you ran ./nodebb setup



  • Login Unsuccessful
    We were unable to log you in, likely due to an expired session. Please try again

    i reinstalled and made sure to set up the Administrator account:

    Administrator username Admin
    Administrator email address .....gmail.com
    Password
    Confirm Password
    Creating welcome post!
    Enabling default plugins
    9/9 05:12:39 [11064] - info: [install/defaultPlugins] customDefaults
    9/9 05:12:39 [11064] - info: [install/enableDefaultPlugins] activating default plugins 0=nodebb-plugin-composer-default, 1=nodebb-plugin-markdown, 2=nodebb-plugin-mentions, 3=nodebb-widget-essentials, 4=nodebb-rewards-essentials, 5=nodebb-plugin-soundpack-default, 6=nodebb-plugin-emoji-extended, 7=nodebb-plugin-emoji-one

    still no luck 😞



  • @pitaj
    root@ubuntu-1gb-sfo1-01:~/nodebb# ./nodebb log

    Hit Ctrl-C to exit

    9/9 05:13:33 [11136] - info: [plugins/emoji-one] Initial startup detected. Downloading emojione assets...
    9/9 05:13:33 [11136] - info: Routes added
    9/9 05:13:33 [11136] - info: NodeBB Ready
    9/9 05:13:33 [11136] - info: Enabling 'trust proxy'
    9/9 05:13:33 [11136] - info: NodeBB is now listening on: 0.0.0.0:6379
    9/9 05:13:37 [11136] - info: [plugins/emoji-one] Emoji are ready.
    9/9 05:14:15 [11136] - error: /login
    invalid csrf token
    9/9 05:14:40 [11136] - error: /login
    invalid csrf token



  • just changed my config.json file from my webURL.com:6379 to localhost:6379
    and somehow I am still able to access my webURL.com:6379 and able to log in to the account.. Although I am getting the "connection to nodebb is lost, attempting to reconnect" box on the right hand corner of the webpage.
    I restarted and turned off terminal ect ect and still the same thing



  • Not sure if this is causing any issues or not but I cannot register as a new user either. It keeps throwing Registration Error . We are unable to log you in, likely due to an expired session. Please try again

    9/9 06:02:31 [11705] - error: Error: listen EADDRINUSE 0.0.0.0:6379
    at Object.exports._errnoException (util.js:1020:11)
    at exports._exceptionWithHostPort (util.js:1043:20)
    at Server._listen2 (net.js:1258:14)
    at listen (net.js:1294:10)
    at net.js:1404:9
    at _combinedTickCallback (internal/process/next_tick.js:83:11)
    at process._tickCallback (internal/process/next_tick.js:104:9)
    9/9 06:02:31 [11705] - error: NodeBB address in use, exiting...
    3 restarts in 10 seconds, most likely an error on startup. Halting.


  • Global Moderator

    EADDRINUSE means there's already a process using that port, probably another NodeBB instance that wasn't shut down. Look up "kill process on specific port" to figure out how to fix that. It sounds like you're having socket.io issues, most likely caused by setting the url in config.json to a different one (localhost) than the one at which you are accessing your site (webURL.com).

    Also, try clearing cookies before logging in.


  • Global Moderator

    Also, that guide you are using is super old, I'd suggesting using the guide on our actual docs instead:



  • @pitaJ thank you for the help!
    If it is socket.io issues do you have any pointers in how to fix it by any chance?


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.