Sidebar vanished, Lavender theme

  • Plugin & Theme Dev Anime Lovers GNU/Linux

    @anooxy I tried, I guess it was a bug.

  • GNU/Linux Admin

    @manuel Sounds like you have an existing NodeBB process running. Make sure there are no orphaned NodeBBs running!

    ps aux | grep node, and then kill -9 with impunity.


  • @julian said:

    @manuel Sounds like you have an existing NodeBB process running. Make sure there are no orphaned NodeBBs running!

    ps aux | grep node, and then kill -9 with impunity.

    after killing and restarting everything i have this js error in admin

    Error: script error for: alerts (require.js:8)

    same for the path forum/admin/ loggers|database|events and forum/admin/plugins/ nameplugin

    some plugins like local emailer and shoutbox won't work in admin

    i still can't see the sidebar in homepage and moreover while navigating through forum when i go back to the home nothing will be loaded (or better, categories are invisible O.o)

    i cannot change theme from lavender to vanilla i.e. O.o


  • when content is not displayed i can see this error in js console

    t.match is not a function (nodebb.min.js:9)

    this will get me mad... need to downgrade


  • When you start NodeBB check your logs. If it says your redis schema is not up to date do a:

    node app --upgrade
    
  • GNU/Linux Admin

    @manuel, please try the following:

    $ cd /path/to/nodebb
    $ ./nodebb stop
    $ git fetch
    $ git checkout v0.4.x
    $ ./nodebb upgrade
    $ ./nodebb start   # or "./nodebb dev" for interactive output
    

  • @julian said:

    @manuel, please try the following:

    $ cd /path/to/nodebb
    $ ./nodebb stop
    $ git fetch
    $ git checkout v0.4.x
    $ ./nodebb upgrade
    $ ./nodebb start   # or "./nodebb dev" for interactive output
    

    note that before running your commands i was on master branch, git-pulled and ./nodebb upgraded without errors
    then i tried to checkout to 0.3.2 to go back but without good results
    and now with your instructions i get this:

    npm http GET https://registry.npmjs.org/marked/0.3.2
    npm http 304 https://registry.npmjs.org/marked/0.3.2

    npm WARN unmet dependency /home/manuel/nodebb/node_modules/passport-google-oauth/node_modules/passport-oauth requires passport@'~0.1.1' but will load
    npm WARN unmet dependency /home/manuel/nodebb/node_modules/passport,
    npm WARN unmet dependency which is version 0.2.0
    npm WARN unmet dependency /home/manuel/nodebb/node_modules/passport-facebook/node_modules/passport-oauth requires passport@'~0.1.1' but will load
    npm WARN unmet dependency /home/manuel/nodebb/node_modules/passport,
    npm WARN unmet dependency which is version 0.2.0
    npm WARN unmet dependency /home/manuel/nodebb/node_modules/passport-twitter/node_modules/passport-oauth requires passport@'~0.1.1' but will load
    npm WARN unmet dependency /home/manuel/nodebb/node_modules/passport,
    npm WARN unmet dependency which is version 0.2.0

    error: [upgrade] NodeBB upgrade could not complete, as your database schema is too far out of date.
    error: [upgrade] Please ensure that you did not skip any minor version upgrades.
    error: [upgrade] (e.g. v0.1.x directly to v0.3.x)

    ...but it's impossible that i have downgraded db schema O.o

    i tried switching back to 0.3.x and re run upgrade, as suggested here but i have still the same error upgrading from 0.3 to 0.4

  • GNU/Linux Admin

    If you get that error on the v0.3.x branch, then you need to switch to the v0.2.x branch, and run the following (note that these commands differ only because they are from a very old version of NodeBB):

    $ git checkout v0.2.x
    $ rm -rf node_modules
    $ npm install
    $ node app --upgrade
    $ git checkout v0.3.x
    $ npm install
    $ ./nodebb upgrade
    $ git checkout v0.4.x
    $ ./nodebb upgrade
    

  • i tried to run 0.4.0 dev + ignore db schema

    i can't navigate admin:

    Firefox cannot connect with server ws://forum.xxxx.com/socket.io/1/websocket/bdaa8lXtzQdKZO8UjoGX. socket.io.js:2
    TypeError: template.match is not a function - templates.js:101

    i can't navigate frontend:

    Firefox cannot connect with server ws://forum.xxxx.com/socket.io/1/websocket/NBqHGkoOWpDRMF3ZjoGb. socket.io.js:2
    TypeError: template.match is not a function nodebb.min.js:11229


  • @julian

    the error happens after 0.4.x checkout.. to be more clear:

        ~/nodebb$ git checkout v0.3.x
        Switched to branch 'v0.3.x'
        
        ~/nodebb$ npm install
        npm http GET https://registry.npmjs.org/passport/0.1.17
        npm http GET https://registry.npmjs.org/validator
        npm http GET https://registry.npmjs.org/nodebb-plugin-mentions
        npm http GET https://registry.npmjs.org/nodebb-plugin-markdown
        npm http GET https://registry.npmjs.org/nodebb-plugin-sso-twitter
        npm http 304 https://registry.npmjs.org/passport/0.1.17
        npm http 304 https://registry.npmjs.org/nodebb-plugin-mentions
        npm http 304 https://registry.npmjs.org/nodebb-plugin-markdown
        npm http 304 https://registry.npmjs.org/nodebb-plugin-sso-twitter
        npm http 304 https://registry.npmjs.org/validator
        npm http GET https://registry.npmjs.org/passport-twitter
        npm http GET https://registry.npmjs.org/marked
        npm http GET https://registry.npmjs.org/pygmentize-bundled
        npm http GET https://registry.npmjs.org/pkginfo
        npm http GET https://registry.npmjs.org/pause/0.0.1
        npm http 304 https://registry.npmjs.org/pkginfo
        npm http 304 https://registry.npmjs.org/pygmentize-bundled
        npm http 304 https://registry.npmjs.org/pause/0.0.1
        npm http 304 https://registry.npmjs.org/passport-twitter
        npm http 304 https://registry.npmjs.org/marked
        npm http GET https://registry.npmjs.org/passport-oauth1
        npm http GET https://registry.npmjs.org/xtraverse
        npm http 304 https://registry.npmjs.org/xtraverse
        npm http 304 https://registry.npmjs.org/passport-oauth1
        npm http GET https://registry.npmjs.org/xmldom
        npm http GET https://registry.npmjs.org/passport-strategy
        npm http GET https://registry.npmjs.org/oauth
        npm http GET https://registry.npmjs.org/utils-merge
        npm http 304 https://registry.npmjs.org/xmldom
        npm http 304 https://registry.npmjs.org/oauth
        npm http 304 https://registry.npmjs.org/passport-strategy
        npm http 304 https://registry.npmjs.org/utils-merge
        npm http GET https://registry.npmjs.org/readable-stream
        npm http GET https://registry.npmjs.org/bl
        npm http GET https://registry.npmjs.org/through2
        npm http 304 https://registry.npmjs.org/readable-stream
        npm http 304 https://registry.npmjs.org/bl
        npm http 304 https://registry.npmjs.org/through2
        npm http GET https://registry.npmjs.org/xtend
        npm http GET https://registry.npmjs.org/core-util-is
        npm http GET https://registry.npmjs.org/isarray/0.0.1
        npm http GET https://registry.npmjs.org/inherits
        npm http GET https://registry.npmjs.org/string_decoder
        npm http 304 https://registry.npmjs.org/inherits
        npm http 304 https://registry.npmjs.org/core-util-is
        npm http 304 https://registry.npmjs.org/xtend
        npm http 304 https://registry.npmjs.org/string_decoder
        npm http GET https://registry.npmjs.org/object-keys
        npm http 304 https://registry.npmjs.org/isarray/0.0.1
        npm http 304 https://registry.npmjs.org/object-keys
        nodebb-plugin-mentions@0.3.1-5 node_modules/nodebb-plugin-mentions
        
        validator@1.5.1 node_modules/validator
        
        passport@0.1.17 node_modules/passport
        ├── pause@0.0.1
        └── pkginfo@0.2.3
        
        nodebb-plugin-sso-twitter@0.1.0-3 node_modules/nodebb-plugin-sso-twitter
        └── passport-twitter@1.0.2 (xtraverse@0.1.0, passport-oauth1@1.0.1)
        
        nodebb-plugin-markdown@0.3.4-2 node_modules/nodebb-plugin-markdown
        ├── marked@0.2.10
        └── pygmentize-bundled@2.1.0 (bl@0.4.2, readable-stream@1.0.26-4, through2@0.2.3)
    
       ~/nodebb$ ./nodebb upgrade
        npm http GET https://registry.npmjs.org/nodebb-plugin-markdown
        npm http GET https://registry.npmjs.org/nodebb-plugin-mentions
        npm http GET https://registry.npmjs.org/nodebb-plugin-sso-twitter
        npm http GET https://registry.npmjs.org/nodebb-plugin-sso-facebook
        npm http GET https://registry.npmjs.org/nodebb-plugin-sso-google
        npm http GET https://registry.npmjs.org/nodebb-theme-cerulean
        npm http GET https://registry.npmjs.org/nodebb-theme-lavender
        npm http GET https://registry.npmjs.org/nodebb-theme-vanilla
        npm http GET https://registry.npmjs.org/nodebb-plugin-dbsearch
        npm http GET https://registry.npmjs.org/nodebb-plugin-desktop-notifications
        npm http GET https://registry.npmjs.org/nodebb-plugin-dwnvtr
        npm http GET https://registry.npmjs.org/nodebb-plugin-emailer-local
        npm http GET https://registry.npmjs.org/nodebb-plugin-emoji-extended
        npm http GET https://registry.npmjs.org/nodebb-plugin-gallery
        npm http GET https://registry.npmjs.org/nodebb-plugin-imgbed
        npm http GET https://registry.npmjs.org/nodebb-plugin-shoutbox
        npm http GET https://registry.npmjs.org/nodebb-plugin-soundcloud
        npm http GET https://registry.npmjs.org/nodebb-plugin-topic-badges
        npm http GET https://registry.npmjs.org/nodebb-plugin-twitter
        npm http GET https://registry.npmjs.org/nodebb-plugin-youtube
        npm http GET https://registry.npmjs.org/nodebb-widget-essentials
        npm http 304 https://registry.npmjs.org/nodebb-plugin-markdown
        npm http 304 https://registry.npmjs.org/nodebb-plugin-sso-twitter
        npm http 304 https://registry.npmjs.org/nodebb-plugin-sso-facebook
        npm http 304 https://registry.npmjs.org/nodebb-plugin-sso-google
        npm http 304 https://registry.npmjs.org/nodebb-theme-vanilla
        npm http 304 https://registry.npmjs.org/nodebb-plugin-mentions
        npm http 304 https://registry.npmjs.org/nodebb-plugin-desktop-notifications
        npm http 304 https://registry.npmjs.org/nodebb-plugin-dbsearch
        npm http 304 https://registry.npmjs.org/nodebb-theme-cerulean
        npm http 304 https://registry.npmjs.org/nodebb-plugin-dwnvtr
        npm http 304 https://registry.npmjs.org/nodebb-plugin-emailer-local
        npm http 304 https://registry.npmjs.org/nodebb-plugin-emoji-extended
        npm http 304 https://registry.npmjs.org/nodebb-plugin-gallery
        npm http 304 https://registry.npmjs.org/nodebb-plugin-topic-badges
        npm http 304 https://registry.npmjs.org/nodebb-plugin-imgbed
        npm http 304 https://registry.npmjs.org/nodebb-theme-lavender
        npm http 304 https://registry.npmjs.org/nodebb-plugin-shoutbox
        npm http 304 https://registry.npmjs.org/nodebb-widget-essentials
        npm http 304 https://registry.npmjs.org/nodebb-plugin-soundcloud
        npm http 304 https://registry.npmjs.org/nodebb-plugin-twitter
        npm http 304 https://registry.npmjs.org/nodebb-plugin-youtube
        npm http GET https://registry.npmjs.org/nodemailer
        npm http GET https://registry.npmjs.org/path
        npm http GET https://registry.npmjs.org/passport-twitter
        npm http GET https://registry.npmjs.org/marked
        npm http GET https://registry.npmjs.org/pygmentize-bundled
        npm http GET https://registry.npmjs.org/passport-facebook
        npm http GET https://registry.npmjs.org/emoji-images
        npm http GET https://registry.npmjs.org/string
        npm http GET https://registry.npmjs.org/marked
        npm http 304 https://registry.npmjs.org/nodemailer
        npm http 304 https://registry.npmjs.org/path
        npm http 304 https://registry.npmjs.org/passport-twitter
        npm WARN package.json path@0.4.9 No README.md file found!
        npm http 304 https://registry.npmjs.org/pygmentize-bundled
        npm http 304 https://registry.npmjs.org/marked
        npm http 304 https://registry.npmjs.org/marked
        npm http 304 https://registry.npmjs.org/string
        npm http 304 https://registry.npmjs.org/emoji-images
        npm http 304 https://registry.npmjs.org/passport-facebook
        npm http GET https://registry.npmjs.org/passport-oauth1
        npm http GET https://registry.npmjs.org/xtraverse
        npm http GET https://registry.npmjs.org/passport-oauth2
        npm http 304 https://registry.npmjs.org/passport-oauth1
        npm http 304 https://registry.npmjs.org/xtraverse
        npm http 304 https://registry.npmjs.org/passport-oauth2
        npm http GET https://registry.npmjs.org/xmldom
        npm http GET https://registry.npmjs.org/passport-strategy
        npm http GET https://registry.npmjs.org/oauth
        npm http GET https://registry.npmjs.org/utils-merge
        npm http 304 https://registry.npmjs.org/xmldom
        npm http GET https://registry.npmjs.org/uid2
        npm http 304 https://registry.npmjs.org/oauth
        npm http 304 https://registry.npmjs.org/passport-strategy
        npm http 304 https://registry.npmjs.org/utils-merge
        npm http 304 https://registry.npmjs.org/uid2
        npm WARN package.json uid2@0.0.3 No README.md file found!
        npm http GET https://registry.npmjs.org/mailcomposer
        npm http GET https://registry.npmjs.org/simplesmtp
        npm http GET https://registry.npmjs.org/readable-stream
        npm http GET https://registry.npmjs.org/directmail
        npm http GET https://registry.npmjs.org/public-address
        npm http GET https://registry.npmjs.org/he
        npm http 304 https://registry.npmjs.org/readable-stream
        npm http 304 https://registry.npmjs.org/public-address
        npm http 304 https://registry.npmjs.org/he
        npm http 304 https://registry.npmjs.org/simplesmtp
        npm http 304 https://registry.npmjs.org/directmail
        npm http 304 https://registry.npmjs.org/mailcomposer
        npm http GET https://registry.npmjs.org/core-util-is
        npm http GET https://registry.npmjs.org/isarray/0.0.1
        npm http GET https://registry.npmjs.org/inherits
        npm http GET https://registry.npmjs.org/string_decoder
        npm http GET https://registry.npmjs.org/rai
        npm http GET https://registry.npmjs.org/xoauth2
        npm http 304 https://registry.npmjs.org/inherits
        npm http 304 https://registry.npmjs.org/string_decoder
        npm http 304 https://registry.npmjs.org/isarray/0.0.1
        npm http GET https://registry.npmjs.org/mimelib
        npm http GET https://registry.npmjs.org/mime/1.2.9
        npm http GET https://registry.npmjs.org/follow-redirects/0.0.3
        npm http GET https://registry.npmjs.org/punycode
        npm http GET https://registry.npmjs.org/dkim-signer
        npm http 304 https://registry.npmjs.org/core-util-is
        npm http 304 https://registry.npmjs.org/xoauth2
        npm http 304 https://registry.npmjs.org/mime/1.2.9
        npm http 304 https://registry.npmjs.org/rai
        npm http 304 https://registry.npmjs.org/follow-redirects/0.0.3
        npm http 304 https://registry.npmjs.org/punycode
        npm http 304 https://registry.npmjs.org/dkim-signer
        npm http 304 https://registry.npmjs.org/mimelib
        npm http GET https://registry.npmjs.org/addressparser
        npm http GET https://registry.npmjs.org/encoding
        npm http 304 https://registry.npmjs.org/addressparser
        npm http 304 https://registry.npmjs.org/encoding
        npm http GET https://registry.npmjs.org/iconv-lite
        npm http 304 https://registry.npmjs.org/iconv-lite
        npm http GET https://registry.npmjs.org/bl
        npm http GET https://registry.npmjs.org/through2
        npm http 304 https://registry.npmjs.org/through2
        npm http 304 https://registry.npmjs.org/bl
        npm http GET https://registry.npmjs.org/xtend
        npm http 304 https://registry.npmjs.org/xtend
        npm http GET https://registry.npmjs.org/object-keys
        npm http 304 https://registry.npmjs.org/object-keys
        nodebb-plugin-dwnvtr@0.1.0-1 node_modules/nodebb-plugin-dwnvtr
        
        nodebb-plugin-soundcloud@0.0.4 node_modules/nodebb-plugin-soundcloud
        
        nodebb-plugin-twitter@0.0.4 node_modules/nodebb-plugin-twitter
        
        nodebb-plugin-imgbed@0.0.0 node_modules/nodebb-plugin-imgbed
        
        nodebb-plugin-youtube@0.0.5 node_modules/nodebb-plugin-youtube
        
        nodebb-plugin-sso-google@0.1.0-2 node_modules/nodebb-plugin-sso-google
        
        nodebb-plugin-dbsearch@0.0.6 node_modules/nodebb-plugin-dbsearch
        
        nodebb-plugin-topic-badges@0.0.4 node_modules/nodebb-plugin-topic-badges
        
        nodebb-plugin-desktop-notifications@0.0.6 node_modules/nodebb-plugin-desktop-notifications
        
        nodebb-plugin-mentions@0.3.1-5 node_modules/nodebb-plugin-mentions
        
        nodebb-theme-cerulean@0.0.13-2 node_modules/nodebb-theme-cerulean
        
        nodebb-plugin-gallery@0.0.3 node_modules/nodebb-plugin-gallery
        
        nodebb-widget-essentials@0.0.21-1 node_modules/nodebb-widget-essentials
        └── marked@0.3.2
        
        nodebb-plugin-shoutbox@0.0.8 node_modules/nodebb-plugin-shoutbox
        ├── path@0.4.9
        └── string@1.8.0
        
        nodebb-theme-lavender@0.0.25-1 node_modules/nodebb-theme-lavender
        
        nodebb-plugin-sso-twitter@0.1.0-3 node_modules/nodebb-plugin-sso-twitter
        └── passport-twitter@1.0.2 (xtraverse@0.1.0, passport-oauth1@1.0.1)
        
        nodebb-plugin-sso-facebook@0.1.0-4 node_modules/nodebb-plugin-sso-facebook
        └── passport-facebook@1.0.3 (passport-oauth2@1.1.2)
        
        nodebb-theme-vanilla@0.0.19-1 node_modules/nodebb-theme-vanilla
        
        nodebb-plugin-emailer-local@0.1.3 node_modules/nodebb-plugin-emailer-local
        ├── path@0.4.9
        └── nodemailer@0.6.1 (public-address@0.1.0, directmail@0.1.6, he@0.3.6, readable-stream@1.1.12, simplesmtp@0.3.24, mailcomposer@0.2.8)
        
        nodebb-plugin-markdown@0.3.4-2 node_modules/nodebb-plugin-markdown
        ├── marked@0.2.10
        └── pygmentize-bundled@2.1.0 (bl@0.4.2, readable-stream@1.0.26-4, through2@0.2.3)
        
        nodebb-plugin-emoji-extended@0.2.2-4 node_modules/nodebb-plugin-emoji-extended
        └── emoji-images@0.1.1
        npm http GET https://registry.npmjs.org/nodebb-plugin-mentions
        npm http GET https://registry.npmjs.org/nodebb-plugin-markdown
        npm http GET https://registry.npmjs.org/nodebb-theme-vanilla
        npm http GET https://registry.npmjs.org/nodebb-plugin-sso-facebook
        npm http GET https://registry.npmjs.org/nodebb-plugin-sso-twitter
        npm http GET https://registry.npmjs.org/nodebb-plugin-sso-google
        npm http 304 https://registry.npmjs.org/nodebb-plugin-sso-twitter
        npm http 304 https://registry.npmjs.org/nodebb-theme-vanilla
        npm http 304 https://registry.npmjs.org/nodebb-plugin-sso-facebook
        npm http 304 https://registry.npmjs.org/nodebb-plugin-mentions
        npm http 304 https://registry.npmjs.org/nodebb-plugin-markdown
        npm http 304 https://registry.npmjs.org/nodebb-plugin-sso-google
        info: NodeBB v0.3.1 Copyright (C) 2013 DesignCreatePlay Inc.
        info: This program comes with ABSOLUTELY NO WARRANTY.
        info: This is free software, and you are welcome to redistribute it under certain conditions.
        info:
        warn: You have no redis password setup!
        info: Beginning database schema update
        info: [2014/1/5] categories active users skipped
        info: [2014/1/5] Re-slugify usernames (again) skipped
        info: [2014/1/7] Update to topic and user posts to sorted set skipped
        info: [2014/1/13] Set up "Registered Users" user group - skipped
        info: [2014/1/19] Remove user search from Reds -- skipped
        info: [2014/1/23] Updating Administrators Group -- skipped
        info: [2014/1/25] Updating User Gravatars to HTTPS -- skipped
        info: [2014/1/25] Activating SSO plugins, if set up -- skipped
        info: [2014/1/30] Fixing language settings -- skipped
        info: [2014/1/30] Adding new topic sets -- skipped
        info: [2014/2/6] Upvoting all favourited posts for each user -- skipped
        info: [2014/2/7] Updating category recent replies -- skipped
        info: [2014/2/9] Remove Topic LastFeedUpdate value, as feeds are now on-demand - skipped
        info: [2014/2/14] Upgrade topics to sorted set - skipped
        info: [2014/2/14] Added posts to sorted set - skipped
        info: [upgrade] Schema already up to date!
        
        NodeBB Dependencies up-to-date!
    
        ~/nodebb$ git checkout v0.4.x
        Switched to branch 'v0.4.x'
    
        ~/nodebb$ ./nodebb upgrade
        npm http GET https://registry.npmjs.org/nodebb-plugin-markdown/0.4.1
        npm http GET https://registry.npmjs.org/nodebb-theme-lavender/0.0.25-0
        npm http GET https://registry.npmjs.org/nodebb-plugin-mentions/0.4.1-1
        npm http GET https://registry.npmjs.org/nodebb-theme-vanilla/0.0.19-0
        npm http GET https://registry.npmjs.org/nodebb-widget-essentials/0.0.21-0
        npm http GET https://registry.npmjs.org/passport/0.2.0
        npm http GET https://registry.npmjs.org/validator/3.5.1
        npm http 304 https://registry.npmjs.org/nodebb-widget-essentials/0.0.21-0
        npm http 304 https://registry.npmjs.org/nodebb-plugin-markdown/0.4.1
        npm http 304 https://registry.npmjs.org/nodebb-plugin-mentions/0.4.1-1
        npm http 304 https://registry.npmjs.org/nodebb-theme-vanilla/0.0.19-0
        npm http 304 https://registry.npmjs.org/nodebb-theme-lavender/0.0.25-0
        npm http 304 https://registry.npmjs.org/validator/3.5.1
        npm http 304 https://registry.npmjs.org/passport/0.2.0
        npm http GET https://registry.npmjs.org/marked/0.2.10
        npm http GET https://registry.npmjs.org/pygmentize-bundled/2.1.0
        npm http GET https://registry.npmjs.org/pause/0.0.1
        npm http GET https://registry.npmjs.org/passport-strategy/1.0.0
        npm http GET https://registry.npmjs.org/marked/0.3.2
        npm http 304 https://registry.npmjs.org/pause/0.0.1
        npm http 304 https://registry.npmjs.org/marked/0.2.10
        npm http 304 https://registry.npmjs.org/pygmentize-bundled/2.1.0
        npm http 304 https://registry.npmjs.org/passport-strategy/1.0.0
        npm http 304 https://registry.npmjs.org/marked/0.3.2
        npm http GET https://registry.npmjs.org/readable-stream/1.0.26-4
        npm http GET https://registry.npmjs.org/bl/0.4.2
        npm http GET https://registry.npmjs.org/through2/0.2.3
        npm http 304 https://registry.npmjs.org/readable-stream/1.0.26-4
        npm http 304 https://registry.npmjs.org/bl/0.4.2
        npm http 304 https://registry.npmjs.org/through2/0.2.3
        npm http GET https://registry.npmjs.org/readable-stream/1.1.12
        npm http GET https://registry.npmjs.org/xtend/2.1.2
        npm http GET https://registry.npmjs.org/core-util-is/1.0.1
        npm http GET https://registry.npmjs.org/isarray/0.0.1
        npm http GET https://registry.npmjs.org/inherits/2.0.1
        npm http GET https://registry.npmjs.org/string_decoder/0.10.25-1
        npm http 304 https://registry.npmjs.org/readable-stream/1.1.12
        npm http 304 https://registry.npmjs.org/isarray/0.0.1
        npm http 304 https://registry.npmjs.org/inherits/2.0.1
        npm http 304 https://registry.npmjs.org/xtend/2.1.2
        npm http 304 https://registry.npmjs.org/core-util-is/1.0.1
        npm http 304 https://registry.npmjs.org/string_decoder/0.10.25-1
        npm http GET https://registry.npmjs.org/object-keys/0.4.0
        npm http 304 https://registry.npmjs.org/object-keys/0.4.0
        npm WARN unmet dependency /home/manuel/nodebb/node_modules/passport-google-oauth/node_modules/passport-oauth requires passport@'~0.1.1' but will load
        npm WARN unmet dependency /home/manuel/nodebb/node_modules/passport,
        npm WARN unmet dependency which is version 0.2.0
        npm WARN unmet dependency /home/manuel/nodebb/node_modules/passport-facebook/node_modules/passport-oauth requires passport@'~0.1.1' but will load
        npm WARN unmet dependency /home/manuel/nodebb/node_modules/passport,
        npm WARN unmet dependency which is version 0.2.0
        npm WARN unmet dependency /home/manuel/nodebb/node_modules/passport-twitter/node_modules/passport-oauth requires passport@'~0.1.1' but will load
        npm WARN unmet dependency /home/manuel/nodebb/node_modules/passport,
        npm WARN unmet dependency which is version 0.2.0
        nodebb-plugin-mentions@0.4.1-1 node_modules/nodebb-plugin-mentions
        
        validator@3.5.1 node_modules/validator
        
        passport@0.2.0 node_modules/passport
        ├── pause@0.0.1
        └── passport-strategy@1.0.0
        
        nodebb-widget-essentials@0.0.21-0 node_modules/nodebb-widget-essentials
        └── marked@0.3.2
        
        nodebb-theme-lavender@0.0.25-0 node_modules/nodebb-theme-lavender
        
        nodebb-theme-vanilla@0.0.19-0 node_modules/nodebb-theme-vanilla
        
        nodebb-plugin-markdown@0.4.1 node_modules/nodebb-plugin-markdown
        ├── marked@0.2.10
        └── pygmentize-bundled@2.1.0 (bl@0.4.2, readable-stream@1.0.26-4, through2@0.2.3)
        npm http GET https://registry.npmjs.org/nodebb-plugin-dbsearch
        npm http GET https://registry.npmjs.org/nodebb-plugin-desktop-notifications
        npm http GET https://registry.npmjs.org/nodebb-plugin-dwnvtr
        npm http GET https://registry.npmjs.org/nodebb-plugin-emailer-local
        npm http GET https://registry.npmjs.org/nodebb-plugin-emoji-extended
        npm http GET https://registry.npmjs.org/nodebb-plugin-gallery
        npm http GET https://registry.npmjs.org/nodebb-plugin-imgbed
        npm http GET https://registry.npmjs.org/nodebb-plugin-shoutbox
        npm http GET https://registry.npmjs.org/nodebb-plugin-soundcloud
        npm http GET https://registry.npmjs.org/nodebb-plugin-sso-facebook
        npm http GET https://registry.npmjs.org/nodebb-plugin-sso-google
        npm http GET https://registry.npmjs.org/nodebb-plugin-sso-twitter
        npm http GET https://registry.npmjs.org/nodebb-plugin-topic-badges
        npm http GET https://registry.npmjs.org/nodebb-plugin-twitter
        npm http GET https://registry.npmjs.org/nodebb-plugin-youtube
        npm http GET https://registry.npmjs.org/nodebb-theme-cerulean
        npm http 304 https://registry.npmjs.org/nodebb-plugin-dbsearch
        npm http 304 https://registry.npmjs.org/nodebb-plugin-emailer-local
        npm http 304 https://registry.npmjs.org/nodebb-plugin-desktop-notifications
        npm http 304 https://registry.npmjs.org/nodebb-plugin-dwnvtr
        npm http 304 https://registry.npmjs.org/nodebb-plugin-emoji-extended
        npm http 304 https://registry.npmjs.org/nodebb-plugin-imgbed
        npm http 304 https://registry.npmjs.org/nodebb-plugin-soundcloud
        npm http 304 https://registry.npmjs.org/nodebb-plugin-gallery
        npm http 304 https://registry.npmjs.org/nodebb-plugin-shoutbox
        npm http 304 https://registry.npmjs.org/nodebb-plugin-sso-facebook
        npm http 304 https://registry.npmjs.org/nodebb-plugin-sso-google
        npm http 304 https://registry.npmjs.org/nodebb-plugin-sso-twitter
        npm http 304 https://registry.npmjs.org/nodebb-plugin-topic-badges
        npm http 304 https://registry.npmjs.org/nodebb-plugin-twitter
        npm http 304 https://registry.npmjs.org/nodebb-plugin-youtube
        npm http 304 https://registry.npmjs.org/nodebb-theme-cerulean
        npm http GET https://registry.npmjs.org/path
        npm http GET https://registry.npmjs.org/nodemailer
        npm http GET https://registry.npmjs.org/passport-facebook
        npm http GET https://registry.npmjs.org/passport-twitter
        npm http GET https://registry.npmjs.org/marked
        npm http GET https://registry.npmjs.org/pygmentize-bundled
        npm http GET https://registry.npmjs.org/emoji-images
        npm http GET https://registry.npmjs.org/string
        npm http 304 https://registry.npmjs.org/nodemailer
        npm http 304 https://registry.npmjs.org/passport-facebook
        npm http 304 https://registry.npmjs.org/path
        npm http GET https://registry.npmjs.org/marked
        npm WARN package.json path@0.4.9 No README.md file found!
        npm http 304 https://registry.npmjs.org/passport-twitter
        npm http GET https://registry.npmjs.org/passport-oauth2
        npm http 304 https://registry.npmjs.org/emoji-images
        npm http 304 https://registry.npmjs.org/string
        npm http 304 https://registry.npmjs.org/marked
        npm http 304 https://registry.npmjs.org/marked
        npm http 304 https://registry.npmjs.org/pygmentize-bundled
        npm http GET https://registry.npmjs.org/passport-oauth1
        npm http GET https://registry.npmjs.org/xtraverse
        npm http 304 https://registry.npmjs.org/passport-oauth2
        npm http 304 https://registry.npmjs.org/passport-oauth1
        npm http 304 https://registry.npmjs.org/xtraverse
        npm http GET https://registry.npmjs.org/passport-strategy
        npm http GET https://registry.npmjs.org/oauth
        npm http GET https://registry.npmjs.org/uid2
        npm http GET https://registry.npmjs.org/xmldom
        npm http 304 https://registry.npmjs.org/uid2
        npm http 304 https://registry.npmjs.org/oauth
        npm WARN package.json uid2@0.0.3 No README.md file found!
        npm http GET https://registry.npmjs.org/utils-merge
        npm http 304 https://registry.npmjs.org/passport-strategy
        npm http 304 https://registry.npmjs.org/utils-merge
        npm http 304 https://registry.npmjs.org/xmldom
        npm http GET https://registry.npmjs.org/mailcomposer
        npm http GET https://registry.npmjs.org/simplesmtp
        npm http GET https://registry.npmjs.org/directmail
        npm http GET https://registry.npmjs.org/he
        npm http GET https://registry.npmjs.org/public-address
        npm http GET https://registry.npmjs.org/readable-stream
        npm http 304 https://registry.npmjs.org/public-address
        npm http 304 https://registry.npmjs.org/readable-stream
        npm http 304 https://registry.npmjs.org/mailcomposer
        npm http 304 https://registry.npmjs.org/he
        npm http 304 https://registry.npmjs.org/directmail
        npm http 304 https://registry.npmjs.org/simplesmtp
        npm http GET https://registry.npmjs.org/core-util-is
        npm http GET https://registry.npmjs.org/string_decoder
        npm http GET https://registry.npmjs.org/inherits
        npm http GET https://registry.npmjs.org/rai
        npm http GET https://registry.npmjs.org/xoauth2
        npm http GET https://registry.npmjs.org/mimelib
        npm http GET https://registry.npmjs.org/mime/1.2.9
        npm http GET https://registry.npmjs.org/punycode
        npm http GET https://registry.npmjs.org/follow-redirects/0.0.3
        npm http GET https://registry.npmjs.org/dkim-signer
        npm http 304 https://registry.npmjs.org/string_decoder
        npm http 304 https://registry.npmjs.org/xoauth2
        npm http 304 https://registry.npmjs.org/inherits
        npm http 304 https://registry.npmjs.org/core-util-is
        npm http 304 https://registry.npmjs.org/mimelib
        npm http 304 https://registry.npmjs.org/mime/1.2.9
        npm http 304 https://registry.npmjs.org/rai
        npm http 304 https://registry.npmjs.org/follow-redirects/0.0.3
        npm http 304 https://registry.npmjs.org/dkim-signer
        npm http 304 https://registry.npmjs.org/punycode
        npm http GET https://registry.npmjs.org/encoding
        npm http GET https://registry.npmjs.org/addressparser
        npm http 304 https://registry.npmjs.org/encoding
        npm http 304 https://registry.npmjs.org/addressparser
        npm http GET https://registry.npmjs.org/iconv-lite
        npm http 304 https://registry.npmjs.org/iconv-lite
        npm http GET https://registry.npmjs.org/through2
        npm http GET https://registry.npmjs.org/bl
        npm http 304 https://registry.npmjs.org/bl
        npm http 304 https://registry.npmjs.org/through2
        npm http GET https://registry.npmjs.org/xtend
        npm http 304 https://registry.npmjs.org/xtend
        npm http GET https://registry.npmjs.org/object-keys
        npm http 304 https://registry.npmjs.org/object-keys
        npm WARN unmet dependency /home/manuel/nodebb/node_modules/passport-google-oauth/node_modules/passport-oauth requires passport@'~0.1.1' but will load
        npm WARN unmet dependency /home/manuel/nodebb/node_modules/passport,
        npm WARN unmet dependency which is version 0.2.0
        npm WARN unmet dependency /home/manuel/nodebb/node_modules/passport-facebook/node_modules/passport-oauth requires passport@'~0.1.1' but will load
        npm WARN unmet dependency /home/manuel/nodebb/node_modules/passport,
        npm WARN unmet dependency which is version 0.2.0
        npm WARN unmet dependency /home/manuel/nodebb/node_modules/passport-twitter/node_modules/passport-oauth requires passport@'~0.1.1' but will load
        npm WARN unmet dependency /home/manuel/nodebb/node_modules/passport,
        npm WARN unmet dependency which is version 0.2.0
        nodebb-plugin-dwnvtr@0.1.0-1 node_modules/nodebb-plugin-dwnvtr
        
        nodebb-plugin-soundcloud@0.0.4 node_modules/nodebb-plugin-soundcloud
        
        nodebb-plugin-twitter@0.0.4 node_modules/nodebb-plugin-twitter
        
        nodebb-plugin-imgbed@0.0.0 node_modules/nodebb-plugin-imgbed
        
        nodebb-plugin-youtube@0.0.5 node_modules/nodebb-plugin-youtube
        
        nodebb-plugin-sso-google@0.1.0-2 node_modules/nodebb-plugin-sso-google
        
        nodebb-plugin-dbsearch@0.0.6 node_modules/nodebb-plugin-dbsearch
        
        nodebb-plugin-topic-badges@0.0.4 node_modules/nodebb-plugin-topic-badges
        
        nodebb-plugin-desktop-notifications@0.0.6 node_modules/nodebb-plugin-desktop-notifications
        
        nodebb-plugin-mentions@0.4.1-1 node_modules/nodebb-plugin-mentions
        
        nodebb-theme-cerulean@0.0.13-2 node_modules/nodebb-theme-cerulean
        
        nodebb-plugin-gallery@0.0.3 node_modules/nodebb-plugin-gallery
        
        nodebb-widget-essentials@0.0.21-0 node_modules/nodebb-widget-essentials
        └── marked@0.3.2
        
        nodebb-plugin-shoutbox@0.0.8 node_modules/nodebb-plugin-shoutbox
        ├── path@0.4.9
        └── string@1.8.0
        
        nodebb-theme-lavender@0.0.25-0 node_modules/nodebb-theme-lavender
        
        nodebb-plugin-sso-facebook@0.1.0-4 node_modules/nodebb-plugin-sso-facebook
        └── passport-facebook@1.0.3 (passport-oauth2@1.1.2)
        
        nodebb-plugin-sso-twitter@0.2.0-1 node_modules/nodebb-plugin-sso-twitter
        └── passport-twitter@1.0.2 (xtraverse@0.1.0, passport-oauth1@1.0.1)
        
        nodebb-theme-vanilla@0.0.19-0 node_modules/nodebb-theme-vanilla
        
        nodebb-plugin-emailer-local@0.1.3 node_modules/nodebb-plugin-emailer-local
        ├── path@0.4.9
        └── nodemailer@0.6.1 (public-address@0.1.0, directmail@0.1.6, he@0.3.6, readable-stream@1.1.12, simplesmtp@0.3.24, mailcomposer@0.2.8)
        
        nodebb-plugin-markdown@0.4.1 node_modules/nodebb-plugin-markdown
        ├── marked@0.2.10
        └── pygmentize-bundled@2.1.0 (bl@0.4.2, readable-stream@1.0.26-4, through2@0.2.3)
        
        nodebb-plugin-emoji-extended@0.2.2-4 node_modules/nodebb-plugin-emoji-extended
        └── emoji-images@0.1.1
        npm http GET https://registry.npmjs.org/nodebb-plugin-mentions
        npm http GET https://registry.npmjs.org/nodebb-plugin-markdown
        npm http GET https://registry.npmjs.org/nodebb-widget-essentials
        npm http GET https://registry.npmjs.org/nodebb-theme-vanilla
        npm http GET https://registry.npmjs.org/nodebb-theme-lavender
        npm http 304 https://registry.npmjs.org/nodebb-plugin-mentions
        npm http 304 https://registry.npmjs.org/nodebb-plugin-markdown
        npm http 304 https://registry.npmjs.org/nodebb-widget-essentials
        npm http 304 https://registry.npmjs.org/nodebb-theme-vanilla
        npm http 304 https://registry.npmjs.org/nodebb-theme-lavender
        npm http GET https://registry.npmjs.org/nodebb-theme-vanilla/0.0.19-1
        npm http GET https://registry.npmjs.org/nodebb-widget-essentials/0.0.21-1
        npm http GET https://registry.npmjs.org/nodebb-theme-lavender/0.0.25-1
        npm http 304 https://registry.npmjs.org/nodebb-widget-essentials/0.0.21-1
        npm http 304 https://registry.npmjs.org/nodebb-theme-lavender/0.0.25-1
        npm http 304 https://registry.npmjs.org/nodebb-theme-vanilla/0.0.19-1
        npm WARN unmet dependency /home/manuel/nodebb/node_modules/passport-google-oauth/node_modules/passport-oauth requires passport@'~0.1.1' but will load
        npm WARN unmet dependency /home/manuel/nodebb/node_modules/passport,
        npm WARN unmet dependency which is version 0.2.0
        npm WARN unmet dependency /home/manuel/nodebb/node_modules/passport-facebook/node_modules/passport-oauth requires passport@'~0.1.1' but will load
        npm WARN unmet dependency /home/manuel/nodebb/node_modules/passport,
        npm WARN unmet dependency which is version 0.2.0
        npm WARN unmet dependency /home/manuel/nodebb/node_modules/passport-twitter/node_modules/passport-oauth requires passport@'~0.1.1' but will load
        npm WARN unmet dependency /home/manuel/nodebb/node_modules/passport,
        npm WARN unmet dependency which is version 0.2.0
        nodebb-widget-essentials@0.0.21-1 node_modules/nodebb-widget-essentials
        └── marked@0.3.2
        nodebb-theme-lavender@0.0.25-1 node_modules/nodebb-theme-lavender
        nodebb-theme-vanilla@0.0.19-1 node_modules/nodebb-theme-vanilla
        info: NodeBB v0.4.0 Copyright (C) 2013 DesignCreatePlay Inc.
        info: This program comes with ABSOLUTELY NO WARRANTY.
        info: This is free software, and you are welcome to redistribute it under certain conditions.
        info:
        warn: You have no redis password setup!
        info: Beginning database schema update
        error: [upgrade] NodeBB upgrade could not complete, as your database schema is too far out of date.
        error: [upgrade]   Please ensure that you did not skip any minor version upgrades.
        error: [upgrade]   (e.g. v0.1.x directly to v0.3.x)
        
        NodeBB Dependencies up-to-date!
    

    i have never been on v0.2.x, when i first installed nodebb it was already on 0.3.x
    so, do i really have to run this?

    If you get that error on the v0.3.x branch, then you need to switch to the v0.2.x branch, and run the following (note that these commands differ only because they are from a very old version of NodeBB):

    $ git checkout v0.2.x
    $ rm -rf node_modules
    $ npm install
    $ node app --upgrade
    $ git checkout v0.3.x
    $ npm install
    $ ./nodebb upgrade
    $ git checkout v0.4.x
    $ ./nodebb upgrade
    

    if i try to run 0.3.x i get this

    info: NodeBB Ready
    warn: [socket.io] Unrecognized message: modules.composer.getUsersByTid
    warn: [socket.io] Unrecognized message: modules.composer.getUsersByTid
    
    /home/manuel/nodebb/node_modules/redis/index.js:516
                    throw callback_err;
                          ^
    TypeError: Cannot read property 'categories' of undefined
        at /home/manuel/nodebb/src/webserver.js:506:41
        at Command.callback (/home/manuel/nodebb/src/categories.js:168:12)
        at RedisClient.return_error (/home/manuel/nodebb/node_modules/redis/index.js:512:25)
        at HiredisReplyParser.<anonymous> (/home/manuel/nodebb/node_modules/redis/index.js:263:14)
        at HiredisReplyParser.EventEmitter.emit (events.js:95:17)
        at HiredisReplyParser.execute (/home/manuel/nodebb/node_modules/redis/lib/parser/hiredis.js:41:18)
        at RedisClient.on_data (/home/manuel/nodebb/node_modules/redis/index.js:488:27)
        at Socket.<anonymous> (/home/manuel/nodebb/node_modules/redis/index.js:82:14)
        at Socket.EventEmitter.emit (events.js:95:17)
        at Socket.<anonymous> (_stream_readable.js:736:14)
    

    damn the moment when i decided to upgrade from 0.3.2

  • GNU/Linux Admin

    @manuel Once you upgrade from v0.3.2, you cannot go back because there are database schema changes that make it incompatible. You can only downgrade if you restore an old database backup snapshot. Please bear with me.

    Please go back to the v0.4.x branch and run the following for me:

    redis-cli get schemaDate


  • @julian "1392411000000"

Suggested Topics

| |