• @rice

    First, what distribution and Web server are you using?


  • @planner

    Ubuntu 12.04 x32 and what do you mean by web server?
    Digital Ocean is the server host if that's what you mean.


  • @rice

    You Web server is the application that makes it possible to access a Web application like NodeBB. In most cases, it's either Apache or Nginx. If you are connected your Droplet via SSH, type sudo service nginx status just to see what it will tell you. I'm betting that you are running Apache, but I could be wrong. You can also trying cd-ing to the /etc/nginx directory. If it does not exist, then you are running Apache.


  • @planner
    Yeah, I'm running Apache.


  • @rice

    Then follow the Apache link I gave in an earlier post.


  • If it's a standard ubuntu 12.04 droplet from Digital ocean you probably don't have a web server installed yet, install a current version of nginx (not from the standard ubuntu repository) and set it up to reverse proxy your nodebb app to port 80. there are plenty of good guides on this on the digital ocean support pages.


  • @rice, check to make sure that you're actually running Apache. It's likely, as @sp4rkr4t suggested, that Apache is not installed. If it's not, it's better to install and configure Nginx, as it is more resource friendly.


  • @sp4rkr4t @planner

    Thanks guys, I checked and yeah neither of those things were installed. I'll go install nginx and start on it now πŸ˜›


  • @planner @sp4rkr4t

    Okay, sorry to ask again.
    I've gotten the proxy down I think, except that there are problems with logging in and the widgets aren't showing on when I go on the domain name (aotforums.com)
    But when I got on (aotforums.com:4567) everything is normal.
    Solutions?


  • @rice

    If you are running Ubuntu 12.04 and you installed Nginx from the repo, you are likely running an old version of Nginx. So, what version of Nginx is installed on the server? Use nginx -v or sudo nginx -v to find out.


  • @planner

    I'm using version 1.1.19

  • GNU/Linux Admin

    @rice We use the nginx stable PPA to install a newer version

    Please note that NodeBB required v1.3.13 or later, if you are using nginx for proxying.


  • @julian

    Thank you so much!!
    It worked, I guess nginx wasn't updated enough

  • GNU/Linux Admin

    Awesome @rice! Glad to hear it.

    Updated the nginx article in our wiki to give better instructions.


  • Can someone help a dummy out (me)?

    I installed nginx and am at the NodeBB wiki page for configuring nginx as a proxy server. So far I've just been following instructions word for word, but I'm a newb and don't know what to do with this:


    NGINX-served sites are contained in a server block. This block of options goes in a specific place based on how nginx was installed and configured:

    /path/to/nginx/sites-available/* -- files here must be aliased to ../sites-enabled
    /path/to/nginx/conf.d/*.conf -- filenames must end in .conf
    /path/to/nginx/httpd.conf -- if all else fails
    Below is the basic nginx configuration for a NodeBB build running on port 4567:

    server {
    listen 80;

    etc etc etc


  • @Kamal-Patel

    I think you should start a new topic and make the question clear.


  • @planner

    Alright, I can do that. Didn't want to post a new topic since I'm sort of embarrassed -- the original poster seemed to also not have too much knowledge, but even he figured out how to set up reverse proxy.

  • Anime Lovers

    @Kamal-Patel

    The way I found the correct file to update was to look in the /path/to/nginx/conf.d/ file for different files. I don't remember what I saw, but I saw it reference something else that vestacp had created for me under /home/username/web. I went to those files and followed the path even more until I found the actual .conf for the domain I wanted to use and modified the config it had created for me to one that proxies the port. You would be correct that you have to edit a text configuration file, I used nano but I suppose you could use emacs.

    When I get home from work I'll see if I can figure out for sure what I did. All I know is that once I found the conf.d folder I was able to trace my way up to the appropriate place.


  • @HolyPhoenix Hold on, did you have a bacon signature yesterday? I made bacon in the oven last night and damn it was crispy! Also, thanks for pointing me in the right direction.

Suggested Topics

| |