nodebb does not work, i can not reset

  • @PitaJ second one with PPA

    note; i have no reputation so i can not sent fast reply.

  • Global Moderator

    @atozsoft ok so what do the following commands output:

    • node -v
    • npm -v

  • root@ip-179:~# node -v
    root@ip-1799:~# npm -v

    i tried node v6 result same.

  • i use this instruction. but no success. buttons does not work, themes does not load etc.

    ubuntu 16.04 , 1 gb ram, aws


    sudo su
    sudo apt-get update


    curl -sL | sudo -E bash -
    sudo apt install -y nodejs
    node -v
    npm -v


    sudo apt-key adv --keyserver hkp:// --recv EA312927
    echo "deb xenial/mongodb-org/3.2 multiverse" | sudo tee /etc/apt/sources.list.d/mongodb-org-3.2.list
    sudo apt update && sudo apt install -y mongodb-org
    sudo service mongod start
    sudo service mongod status


    use admin
    db.createUser( { user: "xxxxx", pwd: "xxxxxx", roles: [ { role: "readWriteAnyDatabase", db: "admin" }, { role: "userAdminAnyDatabase", db: "admin" } ] } )

    use nodebb

    db.createUser( { user: "xxxxx", pwd: "xxxxxx", roles: [ { role: "readWrite", db: "nodebb" }, { role: "clusterMonitor", db: "admin" } ] } )


    nano /etc/mongod.conf

    CHANGE TO...

    authorization: enabled

    sudo service mongod restart
    mongo -u xxxxxx -p xxxxxx --authenticationDatabase=admin


    sudo apt-get install -y git build-essential
    cd /var
    sudo git clone -b v1.5.0 nodebb

    cd nodebb
    sudo npm install --production
    sudo ./nodebb setup
    0_1495537132573_theme settings.png

  • Global Moderator

    @atozsoft ok first of all, you don't need to sudo su if you're gonna write sudo with all the other commands.

    Secondly, you don't need to apt-get install nodejs of you use curl install script way.

    Also, don't git clone, npm install, or nodebb setup with sudo. It can mess up permissions.

  • Global Moderator

    @atozsoft it is possible that those instructions are wrong. Regardless they don't have the apt get install nodejs.

  • @PitaJ ok ok. i am sorry i am new. i want to understand exactly. you say that remove sudo and try again. true ?

  • Global Moderator

    @atozsoft remove sudo from the git, npm, and nodebb commands. Use sudo for the rest, but remove the sudo su

  • @PitaJ same result. i installed succesfully nodebb but themes does not load and some buttons does not work. example save buttons, create post button etc. there is an interesting issue. i tried everything. also redis, also centos. but results same. themes does not load as above image.

    root@ip-1770:/home/ubuntu/nodebb# node -v
    root@ip-1-70:/home/ubuntu/nodebb# npm -v

  • Global Moderator

    Do you get the socket connection failed error message in your browser?

  • @PitaJ if you mean that yes.

    Failed to load resource: the server responded with a status of 400 (Bad Request)
    :4567/ Failed to load resource: the server responded with a status of 400 (Bad Request)
    :4567/ Failed to load resource: the server responded with a status of 400 (Bad Request)
    :4567/ Failed to load resource: the server responded with a status of 400 (Bad Request)
    acp.min.js?v=l54mouudqb8:5 GET 400 (Bad Request)
    u.create @ acp.min.js?v=l54mouudqb8:5
    u @ acp.min.js?v=l54mouudqb8:5
    c.request @ acp.min.js?v=l54mouudqb8:5
    c.doPoll @ acp.min.js?v=l54mouudqb8:5
    u.poll @ acp.min.js?v=l54mouudqb8:5
    u.doOpen @ acp.min.js?v=l54mouudqb8:5 @ acp.min.js?v=l54mouudqb8:5 @ acp.min.js?v=l54mouudqb8:4
    f @ acp.min.js?v=l54mouudqb8:4
    f @ acp.min.js?v=l54mouudqb8:4 @ acp.min.js?v=l54mouudqb8:4
    (anonymous) @ acp.min.js?v=l54mouudqb8:4
    acp.min.js?v=l54mouudqb8:5 GET 400 (Bad Request)

    also there is more socket error on chrome console.

  • Global Moderator

    Then you need to make sure you have the url value in config.json set to the url at which you visit the forum. For example, if you access your site at, then put that in your config.json

  • Thank you very much @PitaJ . now it is ok. but i remember that i had same problem two days ago after configure ngnix and config. site was good also i entered some categories and soon suddenly i got above errors. i hope it wont give error again.

Log in to reply

Suggested Topics

  • 2
  • 5
  • 2
  • 1
  • 5
| |