[SOLVED] nodebb upgrade script freezing

Technical Support
  • Hi,

    I try to upgrade a nodebb instance from some 1.2.x version to the latest (1.4.2 I think)

    When I launch the upgrade it proceeds smoothly until the javascript building part.

    ./nodebb upgrade
    16/1 12:19:43 [18045] - info: [upgrade] Schema update complete!
    16/1 12:19:43 [18045] - info: [build] Building javascript
    16/1 12:19:43 [18045] - info: [build] Building client-side CSS
    16/1 12:19:57 [18045] - info: [build] js => Completed in 14.563s

    At this point the scripts hangs indefinitely, using no CPU time...
    The upgrade can be aborted using ctrl-c, the resulting installation is unusable.

    nodejs is version 4.7.2 from the nodesource distribution, on a Centos 6 server.

  • During the upgrade the following url is fetched: https://fonts.googleapis.com/css?family=Roboto:300,400,500,700

    I was getting a 501 http error..
    It was caused by the proxy, and solved by bypassing it.

    The upgrade completed successfully.

Suggested Topics

  • NodeBB 2factor plugin issues

    Unsolved Technical Support
    0 Votes
    5 Posts

    @julian It seems to be working better now, It still seemed glitchy immediately after upgrading it, but this morning it seems to have chilled out and seems to be working properly.

  • nginx reverse proxy nodebb

    Solved Technical Support
    0 Votes
    4 Posts

    Yes, the url in config.json should be equal to exactly the URL at which you access your site. It usually shouldn't be localhost or an IP address.

  • 0 Votes
    4 Posts

    The common causes for a session mismatch error are usually one of the following:

    1. Mis-configured URL parameter in your config.json file

    If you have a misconfigured url value in your config.json file, the cookie may be saved incorrectly (or not at all), causing a session mismatch error. Please ensure that the link you are accessing your site with and the url defined match.

    2. Improper/malformed cookieDomain set in ACP

    Sometimes admins set this value without realising that they probably don't need to set it at all. The default is perfectly fine. This is what the config looks like:

    Cookie Domain setting

    If this is set, you'll want to revert the setting by editing your database directly:

    Redis: hdel config cookieDomain
    MongoDB: db.objects.update({ _key: "config" }, { $set: "cookieDomain": "" });

    3. Missing X-Forwarded-Proto header from nginx/apache

    If you are using a reverse proxy, you will need to have nginx pass a header through to NodeBB so it correctly determines the correct cookie secure property.

    In nginx, you will need to add the directive like so:

    location / { ... proxy_set_header X-Forwarded-Proto $scheme; ... }
  • 0 Votes
    3 Posts


    I also think it was MongoDB as well because I noticed that the database was set to "0" (default MongoDB on NodeBB setup) and when I changed it to the nodebb database it was as if it was default. Very frustrating but considering the forum was relatively new, not much was lost.

  • 0 Votes
    13 Posts

    The recent Facebook and Twitter update fixed this issue for me now all three login buttons are showing.