Most likely there weren't any major breaking changes for plugins between those two versions. You should be okay to upgrade, although I'd back up your database just to be safe.